32-bit install package contents won't run on low-priv 64-bit machine


I have used Pacquet Builder 3.1.0 to build a 32-bit XLSPadlock-generated .EXE.

I have built, installed, and run 32-bit generated application with Activation Code requirements on 32-bit Windows XP and 32-bit Windows 7 environments successfully, end to end. These machines ALL have Administrative rights. I have built my Pacquet install using “Highest Available” Request Elevated Rights.

On a 64-bit Windows 7 machine (my wife’s laptop from work, which is low-priv (I don’t have Administrator username/password), I have successfully installed the same 32-bit package on this machine, as above. I get no errors, and install completes correctly. When I invoke my XLSPadlock-based .EXE, it correctly runs and asks for an Activation Code. After I enter the Correct Activation Code, the application delays for about 5-10 seconds, and then I get an
application error message:

    Exception ERegistryException in module App.exe at 0202e814

I have installed and run other 32-bit software correctly on this machine.

I figure it’s either a User Account permission issuing or incompatibility of running a 32-bit app on a 64-bit OS.

Is there a remedy for this? I am looking to sell this App, but I don’t think it should have to be a requirement to install and/or run it from a High Priv account.

Further to above, I was able to get user/pass for this machine, and create an Administrator User Account.

When I run the 32-bit app on this 64-bit OS from the Administrative account, I still get the above application error.

This alludes to a 32-bit/64-bit incompatibility.

Is there any remedy for this?

I built a 64-bit app this morning, and ran it on the effected machine, and I get the same Registry Application error noted above. So, it has to be a privilege thing, I would imagine.

Since Activation Code logic requires the ability to write to the Registry, what is the minimum User Account privilege required to accommodate this then?

Thanks in advance.

OK, I definitely isolated this problem to be a Permission issue. I created a “Standard” User account on a 32-bit Windows 7 machine, and installed my simple XLSPadlock-generated .EXE, in which I protected my worksheet.

When I install, run, and provide Activation Code, I get the same registry Error as above. I also get the following information:

Should a simple XLSPadlock-generated .EXE require a high-priv User account to run?


OK, this is NOT a Pacquet Builder issue; it is an XLSPadlock issue.

I re-compiled my spreadsheet application with XLSPadlock, disabling the requirement for Activation Code. I built and installed package from within a Windows 7 “Standard User” account, and the package installed and application ran fine.

The issue is running an Activation Code-enabled XLSPadlock .exe from a Windows Standard User account. There is a problem writing the activated application data to the Registry.

You can close this thread; I’ll open up a new one on XLSPadlock forum.