Access violation at address in module2845D707.dll Read of address-SOLVED

Up until 3 days ago, i have used xls padlock successfully with my files. The problem started 3 days ago after a compile.

When I open the compiled .exe the splash image pops up as it should but before the the file actually opens the caption with the error pops up. The latest exact wording I get is as follows:
“Access violation at address FE9DBCE1 in module ‘2845D707.dll’. Read of address 00000004.” when I select okay or close the error, excel crashes. (the module specified changes with each new compile)

My information

I am using Windows 7 Home Premium
Excel 2013 (and have also tried 2016 with same result)
XLS Padlock v2.2.1

Options I chose in compile:

Excel versions required: 14

Workbook saving/loading:
(I have tried multiple options, each listed below)

Allow secure save, Save changes automatically & Do not allow saving/loading (current)
Save changes automatically & Do not allow saving/loading
Allow secure save, Save changes automatically
Allow secure save
Save changes automatically
Do not allow saving/loading

All selected (current)
None selected

VBA Security:
None selected (current)
Have also tried selecting either one of these and both.

workbook passwords:
empty as no workbook passwords (current)
Have tried using vba password protection and included it here when I did.

Left everything default everytime

Activation Keys
Activation Settings:
No activation key required (current)
Have also tried required activation key and hardware locked
Have also tried required activation key and not hardware locked

Additional settings
Always left both options unselected.

Website Interactions:
None selected

What I have attempted to fix:

Had recently upgraded to Excel 2016, so uninstalled and reinstalled Excel 2013
Checked the .COM addins
attempted to compile with my antivirus (AVG) disabled and enabled.
Attempted compile with various files all with same result.

I am completed out of ideas, my error sounded similar to what was mentioned in this post in this forum:

with the exception of my module being a mixture of numbers and letters.dll that varied with each compile.

I have attempted over a hundred compiles with the different variations over the last 24 hours with no success. Please help, Before experiencing this issue I was able to compile successfully.

My xlsm files work exactly how they should when opened in excel uncompiled.

Please upgrade to version 2.3, this will fix the problem.

gdg support, thank you very much! The problem I was having is now fixed after updating to this most recent release. I greatly appreciate it. I am a very happy and relieved customer :slight_smile: