App not starting in Windows 7 Home 64bit


I have problems running my app on Windows 7 Home 64bit. Windows 10 is fine, Windows 7 Pro is fine, Windows 7 Home 32bit is fine, it’s just Windows 7 Home 64bit specifically that has this problem. I was able to constantly reproduce the problem on several laptops and VirtualBox machines.

Since this does not happen with any app, I managed to strip down my particular app to just one line of code, that causes the app to not start. So I built a test app containing only one line of code in a file called index.php:

echo base64_encode("yI04n6A3o8aJCElK3ZIDnOqB0pO32R7TUA");

On every other Windows 7/10, the app shows up as expected:

On Windows 7 Home 64bit, the app shows up like this:

and hangs indefinitely. Debugging shows that the execution effectively blocks in the base64_encode call and never gets past it.

You can download and test the exe file from here:

and the .exop project file from here:

So please, GDG staff and forum users:

  • can you please run the sample app on a Windows 7 Home 64bit machine and confirm that it does not start?
  • do you have any idea about why this would happen or any advice on how to overcome it?

Thank you!

Which version of PHP and ExeOutput did you use for your project?

Tried with:

  • ExeOutput for PHP 2020.0 and PHP 7.4.1
  • ExeOutput for PHP 2020.1 and PHP 7.4.4
    The result is the same.

And if you try to call base64_encode after the app is fully loaded. For instance, you have a homepage that contains a link to another webpage with the PHP code that invokes base64_encode. Does it hang?

It still hangs. I tried:

<a href="https://heserver/page.php">Click</a>

and in page.php:
echo base64_encode("yI04n6A3o8aJCElK3ZIDnOqB0pO32R7TUA");

The first page loads fine. When I click on the link, nothing happens. The mouse cursor shows the busy state for less than a second (arrow + animated circle), then nothing.

Really strange and it looks like indeed a bug in PHP. But why only on Windows Home edition…
We’re trying to get a Home edition to reproduce the problem.

I just tried the posted test.exe on a Windows 7 Pro (SP1) machine here and it hangs at “just a moment please…” too, so it’s not only the Home edition.

So out of interest I just created a new project from scratch with PHP 7.4 and regardless of what the index.php contains it immediately hangs at “just a moment please…” - even if the code is a simple as:

echo "hello world";

It hangs every time.

Switch to PHP 7.3 though, and everything works fine.

Strangely enough, “hello world” with PHP 7.4 works fine for me (the app starts correctly under Win 7 Home 64bit). The original example (with base64_encode) hangs with PHP 7.4 and PHP 7.3, but it starts fine with PHP 7.2, 7.1 and 5.6.

So the exact nature of this problem may not have one single cause. Instead, it may be the resultant of multiple factors – PHP runtime, Windows runtime, machine speed.

It would be nice if you could tackle the problem. However, the fact that it’s working fine with PHP 7.2 is actually a solution for me, since my app doesn’t rely on any of the PHP 7.3+ features.

And that’s the worst for us too.