Application won't run in Excel 2016


#1

I’m using XLS PadLock with the Woo Commerce Integration on a standard XLSX file. I created it using Excel 2010 on a 64bit Windows 10 Pro Surface. The product EXE compile works great, as well as the activation process. However, in testing one client tried to open the application on their machine and it did not do anything after activation. They successfully downloaded the product, activated the product (woo commerce integratrion), and accepted the license agreement and then… nothing happened. Every time they click the .exe (after activation) the wheel spins next to the cursor for a second or two and then nothing happens. Here are their machine specs:

Dell Optiplex 5050
Windows 10 Pro 64 Bit
Excel 2016 (Office 365)
16MB RAM

The .exe I made with XLS Padlock is a wrapped 32 and 64 bit version in one. I’m going to try separating them to see if this helps, but my guess is it won’t. I have downloaded Office 365 and Excel 2016 on my machine as well and I can’t get the application to open in it. XLS Padlock doe snot work in Excel 2016 either, from what I can tell. XLSPadlock and the Application that I create with it will only open and work in Excel 2010.

Does anyone have any ideas as to what might be happening or how to solve it? I’m already using the latest release of XLS Padlock 2018.2. Everything is working great except for this. I just need to make sure that users on newer PC’s with Excel 2016 or earlier can run the applicaiton without incident. Thank you for your time in advance!


#2

XLS Padlock does work on Excel 2016 and Office 365. The majority of customers are also on Office 365 nowadays, so we would have got more reports if XLS Padlock didn’t work with Excel 2016.
Looks like more a local problem. First, could you try our demo workbook on your computer?
https://www.xlspadlock.com/excel-workbook-demo


#3

Thank you so much for your response. I tried downloading your Markbook DEMO but it froze and crashed my Microsoft Excel 2010 every time I tried to open it.

I am running a brand new Microsoft Surface Tablet with Windows 10 Pro. I have 8GB of RAM.

Because I have two versions of Excel installed, I decided to uninstall Excel 2010 to see if Padlocks was confusing it with Microsoft 365’s newer version of Excel. So I uninstalled Excel 2010. XLSPAdlock could not run or locate Excel after that. I’m running a standard Microsoft 365 Personal License of Excel and XLSPadlock will not show up in it.

I also tried uninstalling XLSPadlock, re-downloading the newest version and trying to reinstall it. Every time I try to run an install it says that it cannot locate Excel before it even gets going. But Excel from 365 is on my machine and running fine with any normal XLSX file. Even the Markbook DEMO says it cannot locate Excel. Any ideas how I can resolve this? I just purchased XLSPAdlock and set up Online Activation with Woo Commerce in the last month and I’ve never seen it work with the newer versions of Excel.

Thanks again for your help. I love the product overall, but just need to get this resolved.


#4

I have some additional information that might help:

When I looked at my applications in my Windows settings it looks like Excel, nor any other Office product, makes the list. You have to dive into the Advanced Settings of “Microsoft Office Desktop Apps” to find Excel, Word, etc, applications in Settings. Is this why XLSPadlock cannot find the program? If this is related, could I uninstall and reinstall it in a way where XLS Padlock would recognize that it is installed? OR is this a bug that needs to be addressed in your next release? Or is there something else that I am missing?

Any help is greatly appreciated! Thanks!


#5

It’s not a bug, it’s because you uninstalled Excel 2010 which removed some registry settings. Try to repair your Office 2016 installation with the Repair function. It will restore the removed registry entries and the Markbook demo will work again.
BTW are you using any antivirus software? Any security software?


#6

Thank you. I uninstalled all of office and then downloaded and installed a fresh copy and XLS Padlock was able to find Excel in Microsoft 365 and connect to it.

I’m going to remake my Application with XLS Padlocks in my new version and then have my client try it again in their Office 365 to see if it works now. We can close this ticket out for now and I’ll open a new one if I continue to have issues.

Thank you for looking into that for me!