Code signing failed - The specified network password is not correct


#1

Hello! – I need to sign a paquet builder package and I’m using a PFX file with a password. I’m getting the following error:

Finalizing Package
- Generating internal resources for package...
- Compressing internal data...
- Merging data into the final EXE file...
- Digitally signing package EXE:
  PFX file: C:\Temp\signingkey-SHA2.pfx
SHA-256 signature used
GSignCode 2.1 -- simple code signing utility
Copyright G.D.G. Software 2011-2016. All rights reserved.
SIGNING ERROR: 
The specified network password is not correct.
Warning: code signing failed, an error occurred.
Closing the package file and cleaning memory...
Note: the archive file was stored in the temporary cache for future builds.

I have used the PFX + Password combination before with other applications to sign .NET applications without issue.
I originally thought that there was an issue with keeping the paquetbuilder project + files on a Windows SMB share, so I copied it down to my PC, changed the references to local file paths, and ran into the same issue locally.

On “Digitally sign package” I have the proper PFX path configured, the proper password, and SHA256 only specified (as it’s a SHA-2 key).

Any ideas?

Best,
-cvo


#2

Strange because this error is indeed network-related. https://social.technet.microsoft.com/Forums/en-US/d19a6209-03f5-4efd-a533-d9971cb8b748/the-specified-network-password-is-not-correct?forum=w7itpronetworking
Double-check your code signing certificate settings in PB.


#3

I double and triple checked these and moved all the files down from our SMB share to run locally. Still running into the same problem. Is there a debug mode or something I can run to figure out where the problem may be?


#4

Unfortunately no, because it’s an error returned by Windows and it doesn’t give more information. Try to manually code sign your EXE file.