Compilation Failed for Script


#1

Everything going wonderful. Been using Paquet for project without issues for two weeks.

Took a short break (30 mins), returned to computer and now get this when trying to build package:

Building Package Stub
Writing resource string table...
- Adding English language.
Writing file properties table...
Managing dialog boxes...
Compiling scripts:
 - script: "mainscript.c"...
fatal error #1061: Can't open input file 'F:\Projects\Student Plans\Software Installer\bin\mainscript.c'.

--> COMPILATION ERROR <--
A fatal error has occurred:
Compilation Failed for Script "F:\Projects\Student Plans\Software Installer\bin\mainscript.c
Compilation aborted; The package has NOT been created.

Very disheartening as software needs to go out this morning. I did not change anything at all. Simply walked away from computer.

How can I fix this?

Paguet Builder 3.6


#2

Upgrade to the last Paquet Builder version or restart the computer to see if it helps.


#3

Seriously? Upgrade. I am using Paquet builder for the same project been working on for two weeks without any issues.

Restart did not help, already tried that. Anti-Virus did not touch the bin files, already verified that too.

Will find another solution to get my software out on time:)

Thanks.


#4

Did you change something to your Windows? A recent Windows update?
There is also nothing wrong for recommending to a user to upgrade to the last version of a software…


#5

No changes. Walked away 30 minutes for coffee. Returned and could not remember if did a full build, so clicked full build and error appeared.

I know there is nothing wrong with you recommending to upgrade. But, put yourself in my shoes. I have a project to complete, get that error and support says try software upgrade to solve when current version been working on same project for two weeks.

Anyway, appreciate your input. Got a solution for now to complete project.


#6

Sure, but something got wrong obviously. If restarting the computer doesn’t help, check if some software isn’t interfering. Turning antivirus program off. Check if there is no other PBuilder.exe process in memory when you get the error.


#7

Was a resolution ever found for the error? I have upgraded to the latest version and reboot my devices several times. I have also uninstalled and reinstalled. Any other suggestions?


#8

Never found solution and had to start a new project. Has happened to me few more times and just gave up on a solution.


#9

Thanks, oldteacher. Does anyone else have any suggestions? I’ve also tried different projects. All projects do this?


#10

Are you using any security software?


#11

I’m using Cylance but I tried disabling it, then reinstalled PB, and tried again. No luck.


#12

Could you post your compilation log?


#13

Compilation Log
Paquet Builder 3.7.0

Package Summary:
Description: Paquet Archive - StartSC.exe
EXE Format: 32-bit EXE (x86)
Type of package: Package for general file distribution - IDStandard
Author: Randy Hastings
Date/Time: 4/27/2018 2:56:30 PM

Checking Settings
Listing files to be compressed…
Analysing user settings…

  • Selected unpacking engine: Small
    Output Directory: C:\Users\rhastings\Desktop
    Settings checked; the compilation can continue.

Building Package Stub
Writing resource string table…

  • Adding English language.
    Writing file properties table…
    Managing dialog boxes…
    Compiling scripts:
  • script: “mainscript.c”…
    C:\Users\rhastings\Desktop\bin\mainscript.c(15): fatal error #1035: Can’t find include file “pbcore.h”.

–> COMPILATION ERROR <–
A fatal error has occurred:
Compilation Failed for Script "C:\Users\rhastings\Desktop\bin\mainscript.c
Compilation aborted; The package has NOT been created.


#14

Make sure you installed PB on a hard disk and you access it not from a network share folder. That could explain why the virtual “pbcore.h” file is not accessible.


#15

Was this ever resolved? I am getting the same error on a new vanilla Windows 10


#16

I got the fatal error failed … on pbcore.h
I tried reinstalling and that does an uninstall first, but not luck.
I then used Windows Programs and Features and uninstalled PB first. Then I reinstalled and now it is fine. All of my project files were still referenced and I selected Recently Used from the opening screen and they were all there. Seems OK now.


#17

There was an issue with PB 3.7 on Windows 10 1804 (April 2018 Update). Make sure to upgrade to Paquet Builder 3.7.1 which includes a hot fix.