Embedded Flash video error - 'Doesn't support property or..'

Hi Support,

One of my customers reported an issue whereby the embedded Flash videos won’t play because of some error, I’m attaching the screenshot e-mailed in by my customer to this post.

I’ve asked them to perform steps outlined in this forum thread:

but they report no improvement.

Can you please suggest what it might be?



You can try to disable Javascript errors: http://www.htmlexe.com/help/faq-disablescripterrors
Maybe your user has some third-party IE add-on that causes this problem.

Thanks, I tried that, but here’s what the customer replied:

“The error message is gone. But, it does not work either. The screen does not answer anything when I click the play button.”

So I wonder what to do next?

The weird thing is that the old .exe files work perfectly for him (compiled with and older version of the software), it’s just that this one compiled with the latest update doesn’t allow to playback those flash videos!

Any suggestions would be much appreciated!



Maybe your customer has set stronger security parameters in its IE zones. It’s definitively a local problem, on his computer. If a JS property is not accessible, then it’s generally a security problem due to some settings the user modified. I also saw that you are trying to use a JS file loaded from a remote server, maybe some cross-site security error.

Thanks for your response, but there is one thing that confuses me.

All 4 customers of mine experiencing this problem (initially there was 1, and now there’s 4) are perfectly able to use the older files compiled with the older version of HTMLEXE - I’m not really sure which one it is - 4.3 or 4.5, but anyway, it’s the one prior to the last update.

So, you’d think that if this problem got something to do with their IE settings etc, they wouldn’t be able to watch those Flash videos in any compilation, yet the older ones work perfectly!

One more thing - I asked them if they’re using Windows 8, but it appears that they’re XP and Windows 7 users.

Basically what I’m thinking is the following - remember I was having an error message popping up when connecting to a server? You fixed it in the last update - it said Cannot change Visible in OnShow or OnHide. So maybe this time around it’s possible that the error message 'doesn’t support property or…" can also be prevented by changing the actual HTMLEXE code?

I know you already said it’s definitely a local problem, and I’m really sorry for doubting your response, it’s just that one thing - if it was a local problem, why those 4 customers can view Flash videos in the older compilations?

Thanks a lot in advance,


Some times ago, I got feedback about similar security issues. It appeared that the problem was an antivirus/security program that modified security restrictions of IE.
Please try to contact your 4 customers and ask them if they are running any antivirus program, antispyware or security? If they modified their security zones in Internet Explorer settings.

Here there is a problem with a remote javascript .js file (URL shown on your screenshot) not able to access an object (probably your Flash player object). This fails generally with security restrictions. Yet, we haven’t made any recent change or maybe Microsoft released a security patch.
Have you tried to compile the JS file into your publication instead?
I haven’t got your source files or HEPX project, so I can only make some guessing.

Thanks a lot, I’ll tell the customers to look into their security settings!