Error while loading the compiled workbook

I get this Error-Message:

Fehler ind der benutzerdefinierten Benutzeroberfläche von XML - Helper:
Zeile: 54
Spalte: 28
Fehlercode: 0x80004005
Steuerelemente können einer integrierten Gruppe nicht hinzugefügt werden: Copy

Please give me information to solve this problem.


I am getting the same run-time-error while loading different with XLS-padlock still trial version compiled workbooks at a different computer. The error doesn’t happen loading it at the original place at the computer with installed XLS-padlock trial version. Both computers have exactly the same EXCEL-Version and same general settings. I was trying every possible setting in the XLS-Padlock-Manager. Even if I sign absolutely no parameter, the run-time-error happens. I guess the problem lies within the ‘Helper’ itself. If I can’t solve the problem I have to choose another compilation software. Sorry for this!

Which Excel version are you using?
And did you modify the ribbon in your Excel workbook (with custom XML helper?) See this for more info

I am using Execl 2010.
I did not make any changes with or without XLM-Helper.
I have send to [email protected] 2 emails with jpg-files with screenshoots to give information about the error messages but I have not get any response. For me it is also so that I have to use a different compiler, if this problem can not be solved in a short time. That I would find very regrettable.

If you haven’t got any reply from us, don’t hesitate to resubmit your email. Sometimes, our spam filter is too efficient.

Please check whether this option “Show add-in user interface errors” is enabled. If yes, then disable it.

  1. Start the application.
  1. Click the File tab.
  1. Click Options.
  1. In the categories pane, click Advanced.
  1. In the details pane, deselect Show add-in user interface errors, and then click OK.


Excuse me, but the support of xls-padlock just copied the text in the provieded link. I am German and I can’t find “File tab” in my english dictionary. I guess you meant the button sequence “File”, “options”, “add-ins” in the file menue. In my complex VBA programmed file there are no add-ins and also no deactivated add-ins at all. I think the support should take the issue seriously and inverstigate itself for the sovling of the problem within XLS-paldlock-hleper!. Finaly I tested the 64-bit-version. But it didn’t help. The EXCEL-installation on the tested computer is defintely a 32-bit-Version. If there is no solution XLS-padlock won’t be of interst any more. I can’t sell my software which starts with an error! Finally I have to inform my partner “”. I am sue he won’t be happy.

Hallo Sorbas2,
ich habe folgendes getan:

  1. Datei -> Optionen
  2. Erweitert
  3. unter Algemein das Häkchen für “Fehler des Benutzeroberflächen-Add-Inns anzeigen” entfernt.
    Jetzt erscheint beim starten der App die Fehlermeldung nicht mehr.

@Suppurt Thank you for your help!

Hallo UTS, congratulations!. In my EXCEL-Workbook there is no hook at “Show add-in user interface errors”. Therefore your advice does not work in my case. I hope that I find a solution till next week, since time is running short.

@Sorbas2: The sequence that UTS described is correct. You should try it again without opening any workbook, because it’s a setting for Excel. Just open Excel from the Windows start menu. I tested this in Excel 2010 (=v14.0.) Maybe you have a different Excel version?
However: not showing errors is not the same as fixing errors !:slight_smile:

In incoming version 2, we fixed the problem indirectly.
FYI, some commands defined in the XML helper for Excel 2013 don’t exist in Excel 2010, that’s why these errors pop up.

@pianist, thanks for the help. Your advice I did already and it worked! But I had to do an additional change in EXCEL-file options, saving: I had to define an actually existing storing place for restoring files. Otherwise my “o.k.” was not accepted by EXCEL-options. Is’nt is crasy? Finally a happy end. (Remark: In may case there were six run-time-error-codes of a different kind!)

Problem fixed in version 2 of XLS Padlock.