EXE Format setting in PBPX file is not persistent (version 3.5.1) - SOLVED

In a Paquet Builder Project I Change the EXE Format from Default 32-bit to 64-bit. After saving the pbpx, Close app and reload pbpx file, the setting is again on 32-bit.
OP System is Windows 10 Pro x64.
Wehen Building the selfextracting file, I use Setting ExeType=1, but it seems not to work as 64-bit, because registry values cannot be read properly on 64-bit.
Do I miss something?

This is strange because in our tests, the EXE format setting is correctly saved when you close and reload the PBPX file.
Do you use some command-line to launch PB?

Regarding the registry problem, add a custom action “Show a message box” to display the value of the %PROGFILESDIR% variable. If the variable points to C:\Program Files, then you have a 64-bit package. Otherwise, if it is C:\Program Files (x86), you have a 32-bit pack.

Thanks a lot for the fast answer!

I used both:

  1. Loading PBPX in PB, changed the Setting “EXE Format” in “EXE Output Configuration”, save, Exit, and reload PBPX file.Then EXE Format was again 32.bit.
  2. In my deployment Tools I use PB command line, and PBD file with “EXEType=1”. Running the selfextracting EXE later, I saw that a custom Action which read from registry (HKLM) did not work (variable was empty) which worked with previous release 3.3.1. That’s why I tested the EXE Format Setting.

Unfortunately I had to finish a Service Release, so I am back to 3.3.1 in the moment. And as I am going into Holiday now, I can do further Tests in 3 weeks only.

I have now idea, why this is working on your side and not on my side. When I am back, and if you want, I can Show the Problem via Teamviwer or similar.

OK. Let us know when you are back.

This has been fixed in PB 3.6. Please upgrade.