EXE just stopped working on Windows/11 with Office 365

We just had an exe fail on Windows 11 with Excel 365…2 hours before a critical annual meeting! It worked yesterday and all we did was compile and provide a signature. Couldn’t use the .exe module. Any ideas?

Followup … worked the morning after. No idea why?

That’s horrible. So sorry to hear that happened. Any clue what happened and do you know if it was only that particular computer or were there other computers affected?
Also curious if you have hardware locking or other security measures instead.
Thanks
Dan

Thesis for teaching out to me.

Only one computer. We have hardware locking. The key was set to expire at the end of June. It was my daughter’s computer and we haven’t distributed it yet. We’re still in a development phase but needed to use it to help a client on a last minute basis. She had windows 11 updates pending even though a reboot didn’t do it. I have her a .xlsx version to use she could work without the vba part. Obviously nothing like the security with your padlock.

Will try to recreate they problem before she takes vacation. Let me know if you want me information about her computer. Works for on my windows 10 desktop and windows 11 surface pro.

Steve Glanstein (cell phone)

Hello,

Spoke with my daughter again.

Here’s a better chronology:

  1. Failure message on .exe
  2. Closed a bunch of windows.
  3. Same failure message
  4. Closed all and rebooted
  5. Same failure message
  6. Connected to internet (considering possible problem with Office 265 verification?)
  7. Same failure message
  8. Installed .xlsx for her to use (obviously no VBA code)
  9. .xlsx worked for limited purposes
  10. Next morning: checked .exe and it appeared to work.

Possibly running an actual .xlsx from Excel made it work?

Steve Glanstein

+1 (808) 423-6766

[email protected]

Notice: This e-mail message is for the sole use of the intended recipient(s) and may contain confidential and privileged information. Any unauthorized review, use, disclosure or distribution is prohibited. If you are not the intended recipient, please contact the sender by reply e-mail and destroy all copies of the original message. Please virus check all attachments to prevent widespread contamination and corruption of files and operating systems. The unauthorized access, use, disclosure, or distribution of this email may constitute a violation of the Federal Electronic Communications Privacy Act of 1986 and similar state laws. This communication does not reflect an intention by the sender or the sender’s client or principal to conduct a transaction or make any agreement by electronic means. Nothing contained in this message or in any attachment shall satisfy the requirements for a writing, and nothing contained herein shall constitute a contract or electronic signature under the Electronic Signatures in Global and National Commerce Act, any version of the Uniform Electronic Transactions Act or any other statute governing electronic transactions.

That is super weird indeed. I’m not exactly sure how to reproduce these conditions that caused this issue. You did have Excel and MS Office installed prior to this, right? When you say you installed the XLSX file, you just mean you copied a file, not an installation of MS office, right?
Thanks
Dan

Correct. Just copied the file so she could use it.

Steve Glanstein (cell phone)

That could be the culprit here. If Office 365 fails to validate the license, the EXE file made with XLS Padlock will fail to load properly. It’s because Microsoft blocks a lof of features if the license has expired or could not be validated.