ExeOutput Viewer Error - file not found, only when using Trident

With having difficulty getting certain things to render properly in the current version of Chromium I thought I would try Trident again but seem to keep getting stuck because:

(a) After the start page, every link I click that works under Chromium fails under Trident. Links begin ghe://heserver/, though I have also tried http://heserver/ and still no joy. I need to specify full URL’s for some of the stuff to work and it works fine in Chromium, why not in Trident?

(b) With the log file option enabled, I get a log file generated that adds a line such as the one following with no explanation or clues as to what has happened or not happened: 17/03/2015 15:47:09 404 ERROR:

© In Chromium if I right click and select Developer Tools, they show up. In Trident if I do the same, nothing happens.

As you can imagine this makes it fairly difficult to troubleshoot. Any help appreciated. Thank you.

For (a), what do you get? A blank page?
© Developer Tools are only available in Chromium. Microsoft doesn’t provide such tools in the webbrowser control for developers unfortunately, only in IE.

Thank you for taking a look. For (a) I get the following error page (see screenshot) and if I click on the contact the author link it opens the About dialog, and for © if as you suggest Developer Tools are unavailable in Trident, perhaps I shouldn’t see a Developer Tools context menu option? Maybe this is a bug you’ve already fixed for v2.

Having now had a play it seems the Developer Tools context menu option appears in Trident depending on whether it is ticked for WebKit or not. The application logic I suspect wants to be something like if Chromium and ticked then show the menu. Are there any other tricks to troubleshoot and diagnose problems in Trident? As you can see the error log entry and error page aren’t helping much as they don’t tell me where it is looking for the page and not finding it.

Well, the “developer tools” in IE bug should be fixed.

If nothing is returned by the debug log, try to enable PHP error log. 404 without any indication in the debug log or error page leads me to think that it’s PHP itself that is returning this error code to the browser.

I have managed to resolve this issue. If you had 2 php files in the project, start.php (set as the default page) and index.php. Among the regular HTML tags start.php might include:

<meta http-equiv="refresh" content="2; url=http://heserver/" />

After the redirect takes place you would be left with the following error, index.php is ignored as the embedded webserver does not automatically guess or append index.php or index.html to a path:

I should have instead specified the following and then it would have worked OK.

<meta http-equiv="refresh" content="2; url=http://heserver/index.php" />

This is perhaps obvious to existing users, not so obvious to those coming from web servers like IIS or Apache. Thank you for your assistance.

Thank you for the solution!