Failed to Load PDF Files in some user environments - SOLVED

I compiled my application with EO 2.0x beta … a user was getting "Failed to load PDF document" for all PDFs he tested. I recompiled today with 2.1 and same results.

I see online documentation that says Chrome is the culprit in most cases when opening PDFs directly in a Chrome browser. It seems to be an intermittent problem.

Could there be some underlying problem in the Chrome engine in EO that is causing this in my user’s environment?

I am at a loss. Only one user is having this difficulty. Any suggestions?


Frank Mc

As an addendum to my issue, I have had the user check his file permissions. The error message in EO when a file permission is not set correctly is “FPDF error: Cannot open …/RNHBconcert/Fiddler On The Roof/Fiddler On The Roof~fhorn1.pdf !” on top of my page background.

The reason I think this may be an internal issue is that the error message “Failed to Load PDF document” seems to be more internal, coming up on a full screen with a dark gray background. Does that key any helpful ideas anyone?

Frank Mc

There is a strange character in your path: ~
…/RNHBconcert/Fiddler On The Roof/Fiddler On The Roof~fhorn1.pdf

Looks like a path problem. Maybe the user is running a virtual environment? Which OS version?

Thanks, but that is a standard character I use in distinquishing parts of a musical score. It is not in the path, it is part of the file name and I have used it in EO for two years now with no problem. On my system, what you see is a result of me removing permissions from that file to see the result, as reported above. When I put permissions back, everything is fine. Thanks for taking a shot, but the “~” is not the problem. It is just a standard ascii character as is the backtick " ` "

Any help is much appreciated. I have this system working fine in several clients … it is only one particular client that is getting the gray screen “Failed to Load PDF document” I do not to find out his OS. Thanks. Have not asked him that.


The user’s OS is Windows 10 and there is no virtual environment. In the EXE’s log file where the error comes up, the entries show:
6/8/17 4:09:35 PM Scheme Request URL start: http://heserver/RNHBconcert/RNH1010%20Accord/RNH1010%20Accord~fhorn1.pdf
6/8/17 4:09:35 PM Resource Request:

The resource request is blank after each “Scheme Request URL” line … is that a hint for your developers?
Frank Mc.

Try to change the name of your PDF file to see if it works. Looks like the name is the cause of the problem.

Sorry, but I don’t think you are reading my full comments. It is not a
file name problem. The system is working on ALL my clients that are
using it. It is this one situation. We are talking about 6,000 song
title files. They are working! It is this one situation that is not.



We understood that it’s only for one person, but our suggestion was to try to change the name of one PDF and ask your user to try the modified version. For us, it’s difficult to help you without source code, example, and of course access to the machine with the failure.

Thanks, we have tried that. I have had the user put some of his pdfs in the folder, and I get the same result with just a regular pdf file name. I will continue to examine his system. I do not have access to it, so it is hard for me also. Answer this for me, please. Does EO use its own internal PDF reader or does it use the default PDF app that is set up on the PC?

I can see I will need to find the answer to my problem on my own. I was just hoping that someone there, or another user, had experienced this issue before and discovered what was going on.


Frank Mc.

It uses the default PDF reader. Maybe your customer doesn’t have Adobe Reader or a similar PDF viewer that embeds itself into browsers? That could explain why the PDF fails to load.

Thanks for that. That will probably be the key. I have done remote
into his pc and it was some program that I was not recognizing. He is
going to install Adobe and set it as default and see if that clears up
his problem. I am very confident that is it.

Frank Mc.

OK. Please keep us informed, thanks!

Finally got the word from my client. When using Phantom PDF or Adobe as default, all is fine. When he has problem is when “Nitro Pro 10” is his default PDF viewer. Seems that it is not cooperating with ExeOutput. Thanks for your help. It all goes back to his environment.

1 Like

Same Problem here.

I´ve tested with Edge, Chrome and Acrobat Reader as default Application and tested with different file names. Not work. Allways the error message. “Failed to load PDF document.”

The latest ExeOutput version includes its built-in PDF viewer based on PDFium (through Chromium). So you shouldn’t need an external PDF viewer?