Formula protection

I have a problem when using formula protection.
When I protect a formula then in the .EXE the cell is showing “#NAME?” instead of showing the result of the calculation.
I don’t have any worksheet password. I am following the steps of your guide.
I am using V2.2.
Probably I am missing something but it’s quite simple example I was doing to test the formula protection.

What Excel version? And some complex formulas cannot be protected: see the user guide.

Excel 2016.
Formulas: TODAY (), SUMIF

Could you try this option:

I have tried it but nothing has changed. The same problem (cells with formula protection are showing #NAME?).
I am testing a simple multiplication formula of 2 cells.
I am using V2.2. Excel 2016 32 bits, Windows 10 64 bits.

And what happens if you press F9 in Excel?

Nothing happens.

You can also press CTRL+ALT+SHIFT+F9 to force all formulas to update.

Does it help?

If #NAME appears, this means that the internal add-in could not be loaded correctly.

When you’re in Excel, select COM add-ins and check that XLS Padlock Formula and VBA protection is turned on.

By pressing CTRL+ALT+SHIFT+F9 nothing change.

XLS Padlock Formula and VBA protection add-in is selected.
Should I enter here some add-in?:

Before generating .EXE the “XLS Padlock Formula and VBA Protection” I turn it on , but after building the .EXE is turn off automatically by the system. I have tested several times and it happens this all the time.
I don’t know if this heps you to know what’s happening.

That’s the reason of the #NAME problem. The internal add-in seems to have been disabled. Did you get a recent Excel crash?

Try to run XLS Padlock Manager to fix all issues.

If not, you might want to check the registry key: “HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Excel\Resiliency\DisabledItems”. Remove entries that correspond to XLS Padlock if any.

I have run XLS Padlock Manager and now the internal add-in is not disabled but the issue of #NAME is still there.

I have checked the registry key and you can see below the only entry I have. I think it is not a XLS Padlock entry.

In an Excel normal workbook, what happens if you enter =PLEvalForm(0) in a cell?

What happen is that the cell shows "#NAME?

Please try version 2.2.1.

I have made a test with new version 2.2.1 but the problem with #NAME is not solved.
When I am in the original Excel workbook I can not insert the function PLEvalForm. You say in the user guide that Excel can recognize the category GXLSForm.GXLSFormula. In my case Excel does not recognize. Any idea why? The add-in is active.

Choose the Developer tab, then Excel add-ins (not COM add-ins). Then please take a screenshot of the Add-ins window.

Requested screenshot:

The COM add-ins screenshot as well:

The GXlsFormula Object should appear in the list of the first window.
Please get the following Zip file, unpack the BAT file to the installation folder of XLS Padlock and run the batch file. It should register the extension on your computer. Make sure Excel is closed.

I did it, but it doesn’t work. This is what I have done:

1-I run the .BAT in the installation folder.
2-In the original excel workbook the screenshot of add-in is this:

3-The screenshot of COM add-in is this:

4-If I insert in the original Excel the formula =PLEvalForm(0), then the cell shows 0.
This is something different than before.

5-I generate the .EXE and when I open it the cells with formula protection all of them show #NAME.
The formula is like this =GXLSForm.GXLSFormula.PLEvalForm(0).