How do I get my external video files to run from my App?

I use the following steps to exclude my huge video files from my App:

  1. File Manager
  2. File Properties
  3. Keep the selected file(s) external (useful for very large resource files)

I desire to keep the video files external from the application. Therefore, my video files are located in a sub-folder called “videos”. However, the App cannot find the files when I use this approach.

Under “Path to the folder where the file will be available:”, I tried entering each of the following values:

%PATH%
%PATH%\videos
“videos”

However, none of these options have worked.

What am I doing wrong?

Which version of HTML Executable are you using? 4.9 or 2022 Beta?

Beta 2022.

Did you encrypt the video files? Or just leave them as is?
And in which format are your video files?

No, I did not encrypt the video files. However, the video files are in WEBM format.

Can you please post the HTML source code you use to play the video file?

Here is a code snippet from the opening web page that is supposed to start playing a video immediately:

						<div id="imCell_2" class="" > <div id="imCellStyleGraphics_2"></div><div id="imCellStyleBorders_2"></div><div id ="imObjectVideo_3_02"><video id="imObjectVideo_3_02_media" src="videos/Preface_REDUCED.webm" preload="metadata" controls>Watch video on &quot;Preface&quot;.</video>
						</div>

I posted a snippet of the actual code that references the video file. However, if it would be more helpful, I can post the entire HTML file.

I have not heard anything from support on this problem for several days. But I think some additional information about this problem would be helpful to you. When I click on the option “Keep the selected file(s) external”, HTML Executable automatically check-marks “Exclude the selected file(s) from the application”. If that second option is checkmarked, I will not be able to see the videos in the finished application.

This problem is a design bug that needs to be fixed. Unfortunately, I will not be the only person encountering this problem with Beta 4.

This is on our TODO list, but it is normal that Exclude files from compilation is on when you choose to Keep selected files external.
In your HTML code, you have this:
src=“videos/Preface_REDUCED.webm”

Suppose your EXE file is at C:\My Doc
So, unless you define a custom path, the ebook app will try to read the video file (if not compiled into the EXE) from
C:\My Doc\videos\Preface_REDUCED.webm
Since you said your video file lies here, I believe that this is a bug and we’ll check that.
A new Beta is anyway scheduled to be published with our second HTML rendering engine, based on WebView2. We’ll make sure that the bug (if confirmed) is fixed in that Beta.

Thank you for your response.

FYI: If I do not include the “Exclude” option, the application plays the videos just fine. Therefore, I believe the problem must be due to a bug.