Invalid Activation Token

I need some advise as I keep receiving the following message with WooCommerce/Wordpress.


What actually this message mean? do I need to make changes to “token”?

The server expects the activation token (what you enter in the field) to be in a specific format, as explained in the guide:

Thanks, gdgsupport.

I am using a free web hosting to test out the online activation.
It works and prompted if a wrong email or purchase ID was keyed in.

But when a correct email and purchase ID was keyed in, the following message pop up.
I have checked and tried a few time but not sure where goes wrong.


Does your server allow remote connections to other servers? Does it support SSL connections?

yes, it supports SSL connections.

If the order is in processing, I can see this message.


If I purposely key in the wrong email address with correct order code, I can see this message


Correct email with wrong order code.


Correct email with correct order ID will show


Do I need to manually key in the activation code in the order when the change from processing to complete? if yes, where to input? I tried to input the activation column but failed too.

As for the hosting Server allow remote connections to other servers, could you elaborate further?

The message “An error occurred while generating the activation key” means that the key generator failed to create an activation key for your workbook.
Verify that your server can reach this URL:
Antispam: replace DOT above by .

Thanks, Gdgsupport,

I need help.
instead of getting the activation key from the WooCommerce, I received the key which was my System ID.


For example:- if I used manual activation, the system ID was found in my WooCommerce.

That’s the normal behavior: in this custom field, the kit stores system IDs separated by |
Thus, the software knows exactly on how many computers the workbook was already activated on.

What exactly does this mean?

Some of my customers have issues that seem to resolve themselves with activating. They get the same error as the OP.

How do I verify that my server can reach the key generator?

what could be the reason to cause the following message?

I tried to redo and reload again and again but the problem still exists.


I would also like to know is the getactivation a subfolder? if yes, what should be the contents inside it?


This error occurs because they entered a wrong activation token (maybe a typo).

You can check the activation kit’s demo PHP script: just try it on your own server and see if a key is generated.

This means that the key returned by the server isn’t compatible with the EXE file. In most cases, it’s because the settings in your .ini are not correct (for instance, the Application Master Key).

It’s a virtual folder used by the kit to redirect the HTTP request to the correct controller. You won’t find that folder and don’t create it, or it will break the setup.

BTW avoid posting private keys on public forums!

Thanks. I manage to get it works.

That’s good news! Thanks for the follow-up!