Myqle connection error

I generated a portable PHP application using exeoutput with portable mysql as backend . It worked for sometime and now it not working and giving the following error.
SQLSTATE[HY000] [2002] No connection could be made because the target machine actively refused it.

Port is unique(44444) not used one. No firewall issue . I allowed it all manually.
Please help.

If the mysql server does not start, check the log: it’s an ERR file created in the “MySQL” folder. You’ll see why it did not work.

I checked the content , here is the content

InnoDB: using atomic writes.
2020-09-26 13:28:10 0 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
2020-09-26 13:28:10 0 [Note] InnoDB: Uses event mutexes
2020-09-26 13:28:10 0 [Note] InnoDB: Compressed tables use zlib 1.2.11
2020-09-26 13:28:10 0 [Note] InnoDB: Number of pools: 1
2020-09-26 13:28:10 0 [Note] InnoDB: Using SSE2 crc32 instructions
2020-09-26 13:28:10 0 [Note] InnoDB: Initializing buffer pool, total size = 128M, instances = 1, chunk size = 128M
2020-09-26 13:28:10 0 [Note] InnoDB: Completed initialization of buffer pool
2020-09-26 13:28:10 0 [Note] InnoDB: 128 out of 128 rollback segments are active.
2020-09-26 13:28:10 0 [Note] InnoDB: Creating shared tablespace for temporary tables
2020-09-26 13:28:10 0 [Note] InnoDB: Setting file ‘.\ibtmp1’ size to 12 MB. Physically writing the file full; Please wait …
2020-09-26 13:28:10 0 [Note] InnoDB: File ‘.\ibtmp1’ size is now 12 MB.
2020-09-26 13:28:10 0 [Note] InnoDB: Waiting for purge to start
2020-09-26 13:28:10 0 [Note] InnoDB: 10.4.11 started; log sequence number 13859285; transaction id 12225
2020-09-26 13:28:10 0 [Note] InnoDB: Loading buffer pool(s) from G:\Barat1\mysql\data\ib_buffer_pool
2020-09-26 13:28:10 0 [Note] Plugin ‘FEEDBACK’ is disabled.
2020-09-26 13:28:10 0 [Note] Server socket created on IP: ‘::’.

I didn’t get anything from above error

i was getting same error
then i installed mysql again like copied and setup mysql again.
still i am getting complaints from customer

we need to work on this for sure

1 Like

Error log doesn’t make any sense.
sometimes even we get error like - “mysql has gone away”
i am also using mysql on portable.

1 Like

Do you have any idea how to go about this issue

place a copy of mysql again and setup it again
then it will be working

Depending on how much data you use for your project, you’ll certainly have to tweak the my.ini settings to increase values such as innodb_log_file_size = 64M etc.

what exactlyshould I do .
does it help ?
I am tried a few tricks. not working.

You’ll have first to reset your MySQL folder (just remove the “mysql” folder and start the same procedure as described in the help to generate a new MySQL folder).

I am also having the same issue. 2002 - No connection could be made because the target machine actively reduce it.

I disabled my firewall and antivirus but still same issue. How can I solve it ?

It sounds like you’re having trouble connecting to the MariaDB server shipped with ExeOutput. Check the MariaDB error log. This log often contains specific details about what might be preventing the server from starting. The MariaDB error log is usually located in the data directory of your “mysql” app’s subfolder. Open the file in a text editor, and scroll to the end of the file. You’re looking for recent entries (those that correspond to the time of the issue) that might indicate what the problem is.