Network issues with path

Alright, so i have a problem.
Im creating a app from my local computer using sqlite as database (works like a charm).
The computer i need the exe on is on a network drive. G:\ or network named\
I successfully did this with the built in mysql.
Now im changing to sqlite database and i ran into som problems.
Before i used exo_getglobalvariable(‘HEPubStorageLocation’, ‘’); to get the path to my exe.
I could upload imaged using exo_getglobalvariable and into another folder in my exe home folder.
(Used virtual G\Data\ at the time, exe would throw “no input file specified”)

Now when i tried to execute my exe i got an error, when i try no virtual folder i get “no input file specified” and when i go virtual folder i get xxxxx
Tried to echo’ing getglobalvariable and get a folder to computers drive C:\USERS…\exeoutput… where all “cookies” are stored and sqlite error that it cant search for the db.

Anyway, im going to try $_SERVER[‘DOCUMENT_ROOT’]; tomorrow but only way for that is to NOT use virtual path for the data folder, and then i get the “no input file specified”…

I cant be the only one putting an exe on a network drive using sqlite ?
How would a guy go about it ?

I also just put the app on the computers drive C:\ and still would not work and threw getglobalvariable to the wrong place…
Dont know what i changed, but something got messed up between switching from mysql to sqlite.

Ok so i did some testing today, only take with me some different copys and i can try again tomorrow.
So a different result today, removed the ssl .dll and now i get the path to .exe right with exoget. Doc root gives same pth.

get an php / sqlite error tho with exoget:
PHP Fatal error: Uncaught Exception: Unable to expand filepath in G:\Data\xxx.php:5
Stack trace:
#0 G:\Data\xxxxx.php(5): SQLite3->__construct()
(line 5 is the “open NEW” line.

Error with ducument root “Cant read database” - same line 5 error construct.

I have named my sqlite database with .db.

When i move the app to computers C:\ it works.
, thought it had something to do with the path having spaces and/or “åäö”, but works fine in C..

So now i dont know really why… Could it be that i need the network name? Now i get G:, the network path is\Gemensam\xxx.

So ill continue testing, with network name and change the .db to sqlite.
Have NO ONE had the same problems?

Ok so now im giving up… Cant make anything work at the network drive tried compiling the sqlite db and extract it to Data/db db. Works like a charm on local disk. Tried compiling the exe on all different ways but no go. Either i get “no input file specified” . Or cant find heserver/index.php, or cant find sqlite database.

Has no one made a aplication that runs over network?
I have been trying to get this thing on the network drive for 5 months now.
Restreicted it access so no go with external mysql server, no go with anything. Sqlite is my last resort.
4-5 computers thats going to share this applikation.

Should i give up and just be done with it?

I feel your pain. Been fighting with this subject for years and still no real way to use a network.

Here is some info that might help, but if you’re looking for a solid solution it is not in any of the links below.

Thnx, was about to give upp but now im on “track” again.
Been plunging sooo many hours into this this weekend. Problem is i need to go to work and test it.
Soon it might be working as good as it get.
First problem solved by storagelocation gave my network G:, replaced that with str replace G: with \\pc.
Then sqlite in WAL worked a bit nah with the one database.
So i did what you did in your post. When a user loggs in, it creates a backup from original database with username.db.
User can read only from theyr copy and only one user will be logged in / database.

There are 2 admins that can write.
So users can just logout and login again to get the most recent “update”.

Not the cleanest, and im sure there will be bugs.

So thanks for the idea, little less frustrated anyway! :slight_smile:

Good idea!

Glad I could at least help a little bit:)