Printing area of excel

I have an issue with the printing format of my excel.

The problem is that when I try to print with .EXE file created by xlspadlock the printing area of the original excel file has changed.
I am using Windows 8.1 64 bits and Office 2013 32 bits.

What happen is that the printing area is taking all the used cells of each sheet of the workbook instead of taking the defined printing area of the original excel file.

Therefore the clients will receive an excel with an incorrect area of printing.

In which language is your Excel?

In spanish.

Looks like a bug of Excel, you should try a VBA workaround to define the print area again when the workbook is opened.

Do you have any updates on this bug?

VBA workaround is not the best option for me.

The same problem here!
win 10 , excel 2010 x32 / x64 , Hebrew edition

I’ll be glad to know when there is a solution.

Cheers.

Which version of XLS Padlock? Did you enable or disable printing?

Both v2.5 and v3.0
"Allow print operations" box is marked

Try this option if it helps:

Otherwise, you’ll have to set your printing area with VBA at workbook load: see https://stackoverflow.com/questions/17623445/set-printing-area-in-excel-2013-using-macro

I have the same issue with the German version (Windows 10, Office 365). In there another solution by now?
The option “Save workbook files against the language of VBA” did not work for me.
And the problem with setting the printing area via VBA is that I want to let the user change the printing area if he wants to. But this way, it would be overwritten every time he loads the workbook.
Furthermore, user defined printing areas are not saved.

Is this option enabled or not?

It is not enabled. But I do not have any protected formulas anyway.

Do you think you can share your workbook file with us? Because in our tests, the printing area is kept.
If yes, you can use wetransfer.com to send us the link for download.

I cannot share the original workbook, but I tried a very simple sheet and got the same results, just defining a printing area, that does not match the used area, and leaving all the XLS Padlock settings on default (except for the 64bit-version).

I also have a workaround now, writing the size of the printing area into certain cells of the sheets and creating the printing areas with VBA when loading the workbook.

1 Like

An additional remark to my workaround: I also have to delete the printing areas before saving, otherwise I get the error again. Because the workbook may be saved without closing, I end up with a rather complicated and time expensive saving routine, as the workbook may well have 50 worksheets:

  1. Delete all printing areas
  2. Save file
  3. Create the printing areas again
    This also leads to the side issue, that the file is always changed after just saving it, but this is not a big problem for me.
1 Like