Problem with mp4 embed


I’m having a problem embedding mp4 video. The files show up OK in the uncompiled web browser, but show the message “Error: unsupported video type or invalid file path”

I’m still on my first video, which is only 2.125 Mb

What could the problem be?


Graeme Hall

What is the HTML code to play your video? And which video format?

Using HTML5

The code is identical to the code in the offline help for mp4

 <video id="video" width="640" height="480" controls>
<source src="video/methane.mp4"></source>
        HTML5 video not supported: Internet Explorer 9 is not installed

Works fine in the web browser but does not work in the compilation .exe

Hello, is there anyone there?

MP4 play well provided that the built-in server is active in your publication. Can you check whether you enabled it?

How do I do that?

Go to the Built-In Server page of HTML Executable.

I am also testing some of the files.
I found the same problem.
I used same code as @charco for video.
And I also enable built-in-server in content file type and also In option of built in server.
And also tried dependencies option.
With http and also with force virtualization
But still it show invalid source in .exe
My HTML perfectly work in other browser and internet explorer.

How I can solve this issue ?

Thank you…
And happy New year 2020…

On the computer that is not playing your video, start the HTML Executable Help and navigate to the “HTML5 video” topic. Does it open?
And do you have a firewall?

Thank you
I tried to run again with same file and everything running perfectly fine.
I think the problem is when I start testing first time I made mistake in coding that’s why video was not showing but after I made Changes in HTML code even after that it was showing error.
That time even with right coding it was showing error
But when I created new fresh .hepx file then everything was working fine with no error.

Strange but great that it works finally for you.

OK, I’ve sorted out the problem.

Everything was set correctly to use the built in server, BUT the action for .mp4 files on the “content file types” was set to “download to disk”.

I reset the .mp4 filetype option to “serve with built in server” and the videos play normally.

I include this to help anyone with the same issue.

Yes, the built-in server method is mandatory for serving MP4 video files.
Thanks for the follow-up!