Secure server using https not working with activation URL

Actually, you can use it as a two-step activation. Generating an online activation key upon a successful payment and recording it into a database, send it to the user (call it a secret code). Ask a user to go to the activation page. Let them submit a system id and the online activation key (secret code) via the form, verify the entry against the database data, generate a hardware activation key and send in to the user as an actual activation key.

This is the the “Manual Activation” way available when the automated online activation fails (no Internet connection, unsupported proxy server or firewall problems).

I’m curious if hardware locked activations is the answer to the above mentioned problems. E-mail your users the online activation key, and then let them create a hardware activation key online using a combination of the online key (as a verification tool) and system ID.

When creating a secure publication and entering the URL of the activation online server, if one uses a NON secure url such as, it work fine BUT if one uses, the program error out. The server I use IS a secure server with a valid SSL cert and can be accessed as such.

Because there are internet connection “sniffers” out there such as “Black Widow”, I would like to use my secure server for the activation kit. Also a secure server connection during activation prevents SQL injections.

Is there a workaround or fix now or in the upcoming version 4?

Any help appreciated.

HTMLExe does not handle https connections right now, because it would require additional dependencies (to handle SSL encryption). Maybe we’ll add it in the future as an option.