Solver add-in error

I have a workbook that uses Solver add-in. After compiling the exe with XLS Padlock I am getting the following error when using solver: Solver: An unexpected internal error occurred, or available memory was exhausted.

How can I fix this?

Have you just checked whether you had enough memory? Is your Excel 64-bit?

Hello,
You can replicate the Solver error by following the instructions in this video link: https://youtu.be/oXAiCBc2sOU

The Excel is 64bits. The problem is not related with the memory, because if I run the original workbook (before compiling with XLS padlock) the macros with Solver runs without any problem.

How about the error that was reported by a customer when opening the .exe?
error0.png

How can these two problems can be resolved?

Thanks for the video.

Tried to click “Load previous data” and got an error in your VBA code:

Entering random data lead to this error:


What values should be entered to reproduce the Solver bug?

For the 2nd problem, did your customer already make a save? Or is it the first time they run the workbook app?

Hi,

After clicking “load previous data” you must check the box “ULS-bending”. See the following picture:


After that, click on calculate in the bottom of the form.

Regarding the 2nd problem: It was on the first run of the workbook app.

Can you try to disable the “Lock VBA project” option in XLS Padlock? And see if it helps?

Here are the new app .exe files (https://www.dropbox.com/s/ybhl8e2sgd3lgpi/bugfix_try.zip?dl=0)

The change that you have proposed was guided to resolve the problem with Solver or 2nd problem in client PC?

Tested in an PC with office 365 and having the same problem with Solver.

Do you have any solution for the problems?

Best regards

Tried again following your recommendation but there is a problem.
Clicking “Load previous data” causes a 1st problem (as reported), so we just click OK for “access denied” (normal since the VBE is forbidden). Then, there is no “Calculate” button anymore as you can see:


If we don’t click “Load previous data” button, what data should be filled in order to launch a valid calculation with Calculate?

Please input the data as presented in the following picture. Some data only appears after you click the checkbox “ULS-Bending” “FRC” (red box in following picture)


After all data is inputted, click calculate.

Hope you can replicate the problem with solver.

Please, really need some feedback on the Solver add-in error.

We were a bit offline due to vacations, but we’ll resume work on your workbook.

Almost passed one month since this problem was reported, and still no response. This is making XLSpadlock useless.