Stream read error

Hi, I’m trying to compile today a php site and i get this:

Writing Application
Writing basic data…
Writing language table…
Compiling skin data files…
Processing file properties…
Collecting internal resources…

  • control resources
  • image resources
    Processing custom HTML dialogs:
  • dlgabout.htm
    Compiling internal scripts for the application:
  • Main Script…
  • Localization Script…
  • Global Commands Script…
  • Internal HTML Dialog Scripts:
    o dlgabout.hex
  • User Scripts:
    o Script "UserMain"
    o Script “Macros”

All scripts were compiled and linked.
Generating application folder…

  • Generating EXE file…
  • Packaging application data up and merging…

The following error has occurred during compilation:
Stream read error

am i doing something wrong?

Also, is it possible to exclude from compressing whole folders instead of bunch of files ? it’s a PITA to select files manually for this -> properties do not compress.

Finally, even for files i have marked as non compressed, during the compilation it still says: compressing filename

thanks in advance

You only gave a partial log, so it will be difficult to find out what is happening.
How large is the compressed data?
You can also select several files once (SHIFT+Click, or CTRL+A) and set up the Properties for all of them.
Yes, it says Compressing but actually it ignores the compression (it actually stores the file in the archive).

indeed the resources were many ( above 1GB ), i removed most of them unneeded and it now compiles. However, i get a php error: fatal error: class COM not found in file.php

my website/application calls a vb6 dll and this .dll exists both in the compiled package and in the system and is registered. Is there something else i must do to the “packed” .dll to make it work ?

“COM” is not enabled in this newer version of PHP.
Download PHP from here and find “php_com_dotnet.dll” file in “/ext” subfolder of the archive. Extract that file in “/PHPRuntime/ext” of ExeOutput, then run ExeOutput and enable that extension in “PHP Settings -> PHP Extensions”.