Unexpected launch error


#1

Case like that:

  1. Compile project to developing path
  2. Run application from exeoutput - works
  3. Run application from windows explorer - works
  4. copy application to USB or HDD partition D or E … - Run copied application - NOT WORKS - showing Unexpected launch error

image


#2

This error occurs when the Chromium engine fails to initialize. Have you tried to recompile it and run again?


#3

I got the exact same error! As soon as I move the exe to another place on the hdd, USB disk or another computer I get this error. The compiled app only works when it is still in the folder where it was compiled. Plz help, I strongly consider buying exeputput but I cant test my application on pther computers!


#4

Please send us you EXE for review. You can zip it and upload it to https://uploadfiles.io/
This is a free file hosting service: after upload, they will give you a URL. Please send us this URL.


#5

Hi, i have just send you my file, recompilation doesn’t work with this problem.


#6

Problem solved! I had not specified the ”Output path” inte Output settings.


#7

I had set output path. I don’t know if you could compile without setting path, it is needed when you create project.


#8

Yes, my EXE was set to be compiled to the Desktop. As soon as I moved it it didnt work, but if I set the path to c:\ the EXE works on every computer I tried it on, when I place the EXE in c:\


#9

So it only works on every computer in defined path???


#10

Apperantly? Strange


#11

Tested your EXE and it works as expected. Have you tried it on a hard disk?


#12

Yes on multiple locations. On system disk, on other partitions and ohysical hard disks. If it works on your computer what could be reason? Maybe somethink in memory is bind to location? Maybe chrome engine? I need to test on other computer.


#13

I tested it again:

  1. copy on another computer - it works
  2. copy exe file to another partition D in that computer - it shows Unexpected launch error :frowning:
  3. turn off laptop, turn on, login to another user, go to partition D, execute compiled php exe, it shows Unexpected launch error

Please test it this way with file i send you.

Best regards

PS.
I think that you store something in registry, or somewhere else which lock compiled program to first run path


#14

We’re trying to reproduce the problem and we’ll fix it.


#15

Did you manage to fix the error?


#16

Yes, it will be fixed in V2018.1. It was related to CEF.


#17

great, I can not wait for the new version :slight_smile:
hope it will be very soon :slight_smile: