V2019 Hanging When Compile

Have not had hanging on compile issue in past with other versions (or least not this bad). Completely locks up and only way to recover is use kill in task manager.


Sometimes hangs on PHP files, sometimes JS file but rarely the same file.

Have tried without success:

  1. Totally disabling virus
  2. Switching between PHP 7.2 and 7.3

Nothing helps and cannot use the software like this. Very time consuming to kill process, restart software and begin the process.

No way to send error report as “Cancel” button will not kill the process…

Could you try this?

There was no specific change between 2019 and 2018.3 for the compression step.

Thanks for tip. Very strange that have never experienced the issue (least not complete hang and have to kill process) until updating to 2019.

Will try it out on both desktop and laptop. Report back after time to see if really a fix for me.

I honestly cannot say what the issue is. Totally disabling virus/firewall seems to help but v2019 still hangs. Same goes for @gdgsupport “disable multi-core compression” - sometime seems to help but after few recompiles, hangs up and must task kill.

At this point totally frustrated and tired of using task kill and restarting.

Nothing changed on my end, have not touched a single system file. Totally new message and I DID NOT abort nor did I press cancel on compile popup dialog:

Please send us a system report:

Validate with OK and click Send Bug Report.

I will review what is included and see for this particular software. When working on software designated for school districts, have a very strict policy must follow. Cannot allow any information that would expose access to school networks. They are very strict and cannot afford to lose my contract.

Silly as it may sound, I have to follow their rules:)

Have other non-school software that can try this on. When get breather, will run and send report from one of those.

@oldteacher Just a quick heads up - I can confirm there’s definitely a problem somewhere…

@gdgsupport I’m getting exactly the same issue, compilation begins then locks up and exeout has to be killed by the taskbar. Compilation freezes seemingly at random, often with the progress bar in the middle as if it’s stuck trying to compress a certain file - but the file it sticks on is pretty random, although in my case it’s usually an image of some type.

I’ve always had lots of different apps open while I’ve using ExeOut in the past and not had a problem, so doubt it could be a memory issue, but in my case the solution here seemed to be by closing Excel, then after restarting ExeOut, compilation would complete as expected. (I’m using Office Excel 2016)

Yes, there is an issue. I cannot find any particular program conflicting with exeout. The only common software between my desktop and laptop (happening on both) is WinSCP. Closing it has no effect so can count it out. Very rarely have any microsoft office products open since mainly use 365.

Happening on two Win 10 (one Pro, one Pro Education) computers. Two different virus programs, disabling them does not really improve exeout hanging issue.

Was thinking maybe the size of directories / number of files might be issue. Not so. Last night had hanging issue on project with total of 28 files.

Beats me, but it has become a real hassle to use exeout.

We upgraded our compressor algorithms, maybe there is a problem there. Anyway, looks like a multi-threading problem. We’ll try to reproduce it.

If that is the case, checking the box to disable is not working. I see no real difference with it checked or unchecked.

And this started only in 2019.0? Not in 2018.X?

Absolutely, no doubt here. Never has this happened in any other version. Noticed it the very first project recompiled with 2019.0.

Something forgot to add: When it happens (and does often) looking at taskmanager, since I keep it open all the time now - very rarely are my resources taking up over 50% memory, disk usage is very low and CPU stays less than 10%. Desktop has 12G memory and laptop 8G. I do not have any large programs open and most of time browser closed and still happens.

May hang on css, js or an image file…

Yep, only in the 2019 version, I’d never noticed any issues in 2018.x and I’d been using it almost daily.

The only other clue that might help track the issue is that for me, it only ever freezes during the first part of compilation, not the 2nd part when compiling php runtime.

With that said, it doesn’t seem to happen often - in fact hasn’t happened again since I reported it the other day - and neither could I pin it down to excel - I just opened 4 excel files at once, several browser windows, multiple firefox, chrome, IE windows + more, and it hasn’t frozen again during compilation yet!??

Could you both try the following build?
Unzip the new Exo4PHP.exe file into the ExeOutput folder. Ensure to make a backup of the original file first.
Then, rebuild your projects. If you still get troubles, please turn on the “Disable multi-core compression” option as shown above:


Will give it a try today. Got some older exeout projects to update so great timing:) Will let you know how it goes after trying it out. Thanks!

Just testing - it’s reverted ExeOut back to trial mode though and it wont let me reactivate it?

Which error do you get when activating it?

Sorry, had to go out last night - I don’t get an error as such. I paste in the code, then upon pressing activate the “Contacting Activation Server” message pops up for a few seconds, then disappears - but EO remains in trial mode.

No problem, but it is really strange as the activation system wasn’t modified at all.
Try this new build (same URL but different file inside Zip)

1 Like