V2020 changing link format

I have been using the same link format since V1.

<a href="pages/example.php" class="btn btn-info" rel="images/button.png" title="">Start Example</a>

After opening project from V2 (2019 or whatever it was called) into V2020, links are being changed, resulting in “No input file specified” white page. For some reason V2020 is changing the link to:

http://heserver/pages/pages/example.php NOTE the extra /pages thrown into link by V2020

I am not inserting the extra “pages/” anywhere.

Have also tried:

<a href="http://heserver/pages/example.php" class="btn btn-info" rel="images/button.png" title="">Start Example</a>

Also end up with http://heserver/pages/pages/example.php

Again, this standard linking has worked since very first time I used your software way back.

Please explain what I should do or look for. You should remember, I am a old, dumb blonde female, and need a walk through…

Boiled down to how V2019 and V2020 handle

header( 'Location: ’ );

When I updated from V2 to V2019, had to change how header location was handled. Now have to change my code back to V2 way for V2020 to work. May sound like crazy woman, but just stating the facts…

No craziness here :wink:
It’s just that in ExeOutput V2 we were using CEF V1 and in ExeOutput V2019 we are with CEF V3. So header redirections were implemented differently. However, there was a bug in V2019 that was fixed in V2020. Your code for V2 and V2020 is certainly the good way to go.

1 Like