Web update not working: SOLVED

Hello guys,

I activated the web update option for my app and compiled the fileds like in the image attached

I uploaded the web update files in my website, here the links for .inf file and .cab file:



Anyway the app says that there is no update available (screen attached).

How can I solve the issue?
Thank you

I updated the .inf file url
Now it is: https://www.marcodepisapia-checkout.com/aggiornamenti-app/catel2dupdate.inf
just to let you check it

Still awaiting for help

My web update is not working either. I get a “no new updates” message. Did you hear back from support?

I saw that you have some numbers in your EXE file. Do you change the EXE filename when you create a new version? The filename in localversion must match the existing EXE file. So, to avoid problems, it is better to never change the EXE filename between updates.
Be sure to also increase the file version in “EXE version info” because some customers missed that point. The video explains that important point.

I didn’t change the name of the exe file, it is exactly the same in the 1.0 versione and in the 2.0 version.
I’m sure to have increased the file version in “EXE version info”.
It is still not working.
Any other idea about the issue?
I sent you all the files that I used in the support ticket n. 3543
Hope it will help you to understand the issue.

I did not change the name of the file either.

Has anyone been able to get this new feature to work?

I think that the app generated with xls padlock can’t read the content of the .inf file.
I tried to delete it from the folder on the web and I receive an error message.
So it means that the app can detect the .inf file, but it doesn’t read the content properly.

Can anyone help us please?

Update about the web update issue: now it works!!

I tried to open the exe file on a different device and it can see the update and download it.
So the problem is about the device. I used the same exe file that didn’t work on my notebook.

Here you are the features of the 2 pc:

  • web update works on PC with Win 7 professional and Microsoft Security Essentials as antivirus software
  • web update doesn’t work on notebook with Win 10 and Avast as antivirus software

Where is the problem?

Please update to XLS Padlock 2022.1 released some days ago. There was a problem with the EXE Universal Mode.

I downloaded it, but it didn’t solve the issue.
Again web update works on 2 devices with Win7, but it doesn’t work on a device with Win10.
Any solution?

Update about the issue:
on Win10 I tried to build a 64 bit only exe file and now the web update feature works normally.
So the issue happens only with a universal single exe file.

There will be a bugfix about that?

Have you regenerated web update files with the updated XLS Padlock? Because generation of .INF files was also a bit modified to avoid the problem with the Universal mode.

Ok, now it works properly. I generated a new .inf file with the last version and everything is ok.
Thank you very much

1 Like