Window Issue with 4.10

There is no runtime module conflict because: stand-alone EXE files don’t use runtime modules anymore, moreover runtime modules shipped with v4.1 supersede the ones shipped with v4.02.
Could you please send me your files by email? Or upload them to and send me the URL by PM.

I have sent the source files by email.

After compiling and running the EXE, click on Article 6 and a copy of the main window, “_henewinstance”, will open and then scroll all the way to the bottom and select HTML Exec site or the StorageCraft site. Both are using the “hepopup[xyz]” to open a website.

FYI, I installed 4.10 for the first time in a VM, compiled and ran the EXE in the VM and on the host with the same issues. Flashing fickering, as stated above and you cannot resize or do anthing with the child window.


I believe I may be having a software conflict with the EXE compiled with 4.10. I had cleaned out my temp directory. After running the 4.10 EXE with the runtime embedded, I experienced the problem 1 out of 5 times. Then I loaded VMware Workstation 7.15 and experienced the problem 3 out of 3 times. The symtoms, listed earlier only appear with after compiling with 4.10 with the runtime embedded. This never happened with 4.02, with or with out the runtime embedded.

I am not saying that the VMware is the conflict because it happened 1 out of 5 times before loading. [quote=“gdgsupport”]There is no runtime module conflict because: stand-alone EXE files don’t use runtime modules anymore, moreover runtime modules shipped with v4.1 supersede the ones shipped with v4.02.
So far, here is what I have been able to determine about the runtimes. The following (2) tests were compiled with 4.10 with the option, Do not merge the runtime module: I’ll distribute it separately. File size = 440kb.

  1. In a clean VM, with NO HTML Exec and runtimes installed, I get a popup window with, HTML Executable IE Runtime Module is missing and that Version required:

  2. On the host, WinXP SP3, or a VM, WinXP SP3, with HTML Exec and/or runtimes installed, the EXE runs fine with no symtoms of the problem when using the “_henewinstance” to open a website in a window. Both run fine with numerous tests. I am assuming these are running fine with the 4.02 runtimes since the 4.10 runtime is not embedded.

I want to test on a reboot where there are no instances of VMware services/drivers being loaded without uninstalling the software and test the results. Also, I will uninstall 4.02 and do cleanup and reinstall 4.10 to see if that makes a difference.

Since I am the only one seeing this problem, do you have any suggestions or possibly a debug version of the 4.10 runtime I could try on trying to isolate the possible confllicts or if you have any other questions, on the above, please let me know?

I will post more information when the additional tests are completed.

Merry Christmas…


In a test situation that I had previously built, I have found the following. This did NOT occur and works fine in 4.02 and no code changes before compiling with 4.10. Using VM’s, I have 4.10 in one and 4.02 in another.

Basically, these tests are opening different types of windows with “_henewinstance”, “_heexternal”, target="_blank" and “hepopup[xyz]”

  1. From the index file, I am using the “_henewinstance” to open up a copy of the main window with basically the same links.

  2. From that page, I select “hepopup[xyz]” with a website. The window opens in normal mode, as expected, however, the window is blank and the areas highlighted in red on the attachment are flashing. Take away the focus and the site will load. Give it back to the focus and the areas start flashing again. With it still in normal mode, you cannot resize or close the window as it appears to be in a loop. You have to remove it through the task manager.

With 4.02, this works as expected.

While writing this, I decided to do another test. I recompiled without the runtime being embedded and it works fine with 4.10. To see if there was an issue with the runtime versions, I ran the 4.10 EXE in a clean VM, meaning no previous runtimes and it worked as expected. It appears to be conflicts between the runtime versions.

I will clean out the runtime on a VM and test it again and report back.

Let me know if you have any questions, on the above.

FYI, with the log now showing elapsed time, my average compile time, on the above tests, is around 5 seconds, with fastest one clocking at 2 seconds, in a VM.



I tried to clean the runtime from a VM. Still experiencing the flashing, as above.
Went back to the clean VM and ran it the second time and it is now experiencing the same problem.

If support cannot duplicate this, I will send the files needed.


OK. I’ve received your files, and I’ll study this issue for the next small update.

I’ll study this issue for the next small update.

Tech Support,

Interesting update on the error reported above. This time with “_blank” instead of the “hepopup[xyz]”.

If the main EXE is in a normal window and then click on a link with “target=_blank” and then the stuttering starts in both windows. The only way to exit is to kill the process from the Task Manager.

However, if the main EXE is maximized and then click on a link with “target=_blank”, the child window opens normally and you can exit both windows normally. In the same session, if the main window is set back to normal and then click on the link with "target=_blank. then the stuttering starts again.

The difference, is when using the _hepopup], the second or child window is the only one stuttering since there are two processes running. If using the _blank, both windows are stuttering since there is only one process running.

Hope this helps in your troubleshooting this problem.


I emailed a zip file with both issues along with the hepx file.