Exchange File Is Empty Error +an issue with typing in text fields


#1

Not sure what this could be related to, but since upgrading to v2019 I’ve been getting this error occasionally:

Exchange_on_first_run

This is when using PHP 7.3 - not yet sure if it happens with v7.2, but I’ve never come across it before in v2018

Also, a totally separate issue, I’m occasionally having problems placing the cursor in text fields, most of the time it works fine and I can type into them as normal, but occasionally when I click into a text field, the cursor doesn’t appear and it’s impossible to type. The only way to get it to work again is by closing my app and restarting the exe. When the problem occurs, it affects all text fields within the entire app, even those on totally separate pages.

Could this new setting in V2019 be anything to do with it?:

By default, internal resources cannot be downloaded anymore (for instance, Download menu on default HTML5 video player). You can allow downloads by setting the global variable exointdownload to 1 at runtime (search in documentation for example)."

Any clues?

EDIT: So regarding the text field issue, I’ve found a way to reproduce it & think it might be something to do with the way the new version of cef hadles certain javascript functions - I could be wrong, but I’ll report back after more testing…


Error: alert javascript + input form
I can not enter data in my forms
#2

This error message is the same as you got previously (index out of bounds). Instead, we replaced it.
Looks also like that the CEF version we used had some bugs, as an updated CEF has been released since. We’ll integrate it to the next update 2019.1.

Do you call several PHP scripts at the same time?


#3

Yes, there is quite a lot going on - unfortunately I’ve not had time to investigate further yet - but as soon as I do I’ll post more detailed info.


#4

Ahh, that explains the first issue then!

So is this possibly the cause of the text area focus issue - or should I investigate further and report back with more info? - apart from upgrading to php7.3, nothing has changed in my code since v2018.3 which worked fine.


#5

Not sure, you’ll have to test it when the new update is out. We’re not able to reproduce your problem.


#6

@gdgsupport Okay, while I can easily reproduce the text field issue here, because there’s so much going on in my app I still haven’t had time to pinpoint exactly what’s causing it - I will track it down and let you know as soon as I can.

However, what I can tell you so far is that to resolve the problem all I have to do is click away from the apps main window on the desktop then click back to the app and text field focus begins to work again as expected.

Thinking it could be related to this:
https://bitbucket.org/chromiumembedded/java-cef/issues/310/unable-to-focus-html-text-field-after-alt

??


#7

I’ve figured it out… there may be other ways the problem could occur, but this is a basic example where a javascript alert causes the problem…

This code should reproduce the issue:

textarea-focus-bug

Compile the code and try to type in textarea - at first it will work fine, then click the button to trigger the JS alert message, then close the message and try get focus on the textarea - it won’t work.

The only way to get focus back is by clicking away from the window, and back again and it will begin working

  • might it be a cef issue or an ExOut bug?

#8

Thank you for your sample. We’ll test this.


#9

Did you manage to reproduce it at your end?


#10

Okay, so I’ve investigated the issue in each new version of CEF testclient and it’s definitely a CEF bug.

The last version of CEF NOT to exhibit this behaviour was 3.3497.1841 - thus the reason ExeOutput v2018.3 worked okay.

All versions and builds of CEF beyond that point have the bug, including all the most recent builds.

Looks like I’d better file a bug report on the CEF forum - I’ll keep you posted!

[EDIT] Bug report posted here


#11

That’s actually bad news, because we can’t fix it ourselves. Thanks for the bug report and hopefully it will be fixed soon.


#12

Yeah, I figured that - frustating for sure!

Hopefully they’ll track it down soon, from reading through other bug reports it looks like a few of them could be related.

In my case it’s not a complete showstopper, I only use alerts for occasional debugging, and now I know what to do I can easily click away from the window and back again and everything’s okay - but in some people’s apps that might not be the case - it affects confirm dialogs too.


#13

I’ve now posted an actual HTML file that should reproduce the issue on Win7 to the bug report thread - but not yet tested on Win 8 or 10 - would be good if somebody here could try to reproduce on different systems.

  • @gdgsupport Regarding the Exchange File Empty error - you mentioned the Index Out Of Bounds error message was replaced with Exchange File Empty - what does “Exchange File Is Empty” mean? - I still get the error occasionally, but hard to say exactly what’s causing it - although it’s possibly still related to the technique I use to display images from a users PC here ?.

#14

Using HTML code @kim posted on CEF issue can confirm bug exist in Win 10.

Video_2019-02-08_115620


#15

Thanks Susan, I’ve posted the vid to the bug report - fingers crossed they’ll fix it soon!


#16

Excellent news:

Fixed in master revision f85816f, 3683 branch revision 59d1f01 and 3626 branch revision ad428f3.

Tested in the latest testclient app, and all good at this end.

@gdgsupport Do you have a timeframe for the next ExeOut update? and would be great if you could let me know what the “Exchange File is Empty” error means - I’m still looking for clues to track down the cause of the issue!


#17

We’re working on the update too, but we will also take this opportunity to fix some other problems reported.


#18

Just to clarify, regarding the Exchange File Empty error; is that likely an issue with ExeOut at your end then or should I contiunue trying to find a consistent way to reproduce it here? One thing I have noticed is that it seems to be more likely to happen upon first run of a freshly compiled exe where I’d first cleared the CEF and PHP runtime cache via the button in General Settings.

That’s not to say it doesn’t happen at other times too (which I think may be related to the image display technique I use), but it does seem more likely to occur on first run of new exe compiled after clearing the runtiume caches.


#19

Just a quick heads up for @gdgsupport regarding the next version of ExeOut - I’ve discovered a new issue (unrelated to this thread) that affects all builds of the latest version of CEF (3626) that I’m guessing you’ll be planning use in the update.

It’s quite major for me, and I’d imagine it’s likely to affect others here too - I posted a bug report here.

Would be great if some of you could download the 3626 cef testclient and test in Windows 10 and maybe even vote on the issue so we can get it fixed as soon as poss!


#20

@kim Done and same issue on Win10.

in case anyone else needs link to test CEF, look at http://opensource.spotify.com/cefbuilds/index.html and download the “Sample Application” version.