Can't execute Exo4Php.exe. Maybe because ARM64?

Hi,
I changed the computer and now I’m using a Macbook M1.
Using Parallel Desktop as VM, and Windows 11.
Downloaded, installed, ok.
When I try to run the program, nothing happens.
I thought it could be the MS VC libraries. Installed all, 2010-2015, x86, x64, ARM64… No success.
Any thoughts?
This is the Win11 settings:
https://pasteboard.co/WAcMzCv12rdF.jpg

Hi @swimitup ,

I am not an Apple user but I had a similar issue.
In my case someone tried to run the executable inside of parallels on a mac and it did not start properly. In many cases the screen stayed white/ empty.

Within parallels there seems to be a setting in which you can “share the desktop” between host and client. Sorry, I do not know the exact settings name. The user disabled that feature and afterwards the issue was solved.
Maybe you can check that setting as well.

Thanks for the tip. I isolated the VM and stop the sharing, but still the same result: you double-click the icon, it seems to execute, but nothing shows up in screen.

Here’s some screenshots of Parallels configuration that make your VM isolated.

PS: naturally, I restarted the machine so the options could be applied.

Found an official solution, provided by Parallels itself:

If you’re trying to run an application/game in Windows 11 on Arm, and it doesn’t start or crashes right upon launch, we advise you to enable compatibility settings: right-click the application icon > Properties > Compatibility tab > Change emulation settings > tick all the options as shown in the screenshot below:

In the case of Exo4Php.exe, you also need to check the option “Disable Hydrid execution mode”.

Now the app runs as expected.

Hope this helps others, even for any other app than ExeOutput.