Cron issues in new Exeoutput 2018.2


#1

Problem with cron in exeoutput 2018.2
It works but displays windws like this

image

How can I disable notifications like this in general, not only with functions as below?
It happen when i use in cron php file function
$variable = file_get_contents(URL);

Generally it works, but sometime it happens and display window as i shown above, but need to disable it.


#2

I think that it is the reason - greyed checkbox in PHP Debugging :frowning:

is “Display PHP error messages at runtime” enabled by default and can’t be using (greyed checkbox) :frowning:


#3

The error means that the PHP process ended prematurely, probably due to a crash. Do you start several CRON jobs in parallel?


#4

only one process every 3000 ms, which get REST response from remote webserver, remote webserwer response is

echo date(“Y-m-d H:i:s”);

I left application for last night and 100% response was done, but there were 8 windows like this above. As i told, even when it was an error windows, work was done :frowning:

Can you hide error messages windos like this, by option or by default?


#5

The error should be hidden in ExeOutput 2018.3.


#6

It is very important for applications to not display windows like this for clients. When are you going to release version 2018.3?


#7

It is available now.


#8

Great, thank you for the very fast fix, keep it up :grinning: