Exclude Folders in ExeOutput (doesn't exclude folders within excluded folders)


Thanks for the latest update!

I’m just testing and have run into one old issue I’ve been bugging you guys about for ages… :wink:

I build from the development folder and have several folders that need to be in the root (where the index file resides) for correct operation of my app. However, they don’t need to be compiled into the exe.

The problem is this, within each folder lies several hundred more folders, and within each of those there are yet more folders and each can contain many files. Also their contents changes as I work with the app and additional folders are created within those that would also need to be excluded each time before compiling.

The current behaviour of the exclude folder feature is useless for excluding so many folders as it doesn’t automatically exclude the contents of folders within the excluded folders - each has to be exclude one by one which is a major pain - or in my case, impossible.

If it worked as expected all I’d need to do is exclude 2 folders at the top of the file tree.

Is there any chance of an update to fix the issue?

Yes, for some reason, your request was no more on our TODO list. It is back and we’ll try to implement it in a next small update.

1 Like

Actually it works but, since you have an old project, you must first click Clear in File Manager to remove the entire folder(s), then click Update. File Update doesn’t remove files from excluded folders. Indeed, it only removes files that don’t exist but it won’t add files that are in Excluded folders.

Ahh, okay… I’d not even attempted to use the “clear” button, I had no idea it had anything to do with excluding folders being as there was a separate button! - infact I thought it might completely delete the folders from the hard drive - the onmousover text says “Destroys the selected folder, including it’s files and subfolders”

It does seem to work though, but only temporarily - although the folders and their contents do seem to be removed from the Application Root list, they still reappear in the folder tree upon clicking “update” or reloading a project.

Also, it still doesn’t seem to be able to cope with folders that contain a large number of subfolders and files - at least not in my case.

First I tested with my current project and used the clear button to exclude a couple of folders that contained just a few subfolders that contained a small number of files - they seem to have been removed and dissappeared from the file tree in the display (although as explained, when I hit update they reappear in the display - whether they are still getting compiled in the app I’m not so sure).

However, when I tested with a new project with the root as my main development folder then used the clear button to remove the two main folders I really need the app to ignore that contain lots of subfolders and files (probably about 30 subfolders, each containing several more subfolders, with each of those containing anything up to 500 files) the app throws an error.

Basically, the clear button seems to work fine at first and the two main folders initially appear to have been removed from the project, however, after removal, when clicking update, or attempting to compile, or attempting to save the project, exeoutput freezes and after a while shows an error message (with the option to send a bug report).

Could it be that maybe the live file update feature is still be attempting to scan the “destroyed” folders further down the file tree for changes regardless of whether they’ve been removed with the clear button or not? - thus the reason it takes so long & appears to freeze when the folders contain so many files? (when the error report option appears, I click to continue with the app, and wait… and wait… and wait… and nothing happens - so whether it’s just taking a long time or actually crashing I’m not yet sure…)

Any clues??

(I can send a bug report if you like?)

Just to clarify though, are you saying I should be able to create a new project, then simply select the folders to be “destroyed/cleared” in the file tree in the left of the main File Manager window, click the clear button for each one, and that should exclude them and the contents of their subfolders permanently from future compilations?

No need to press Clear for a new project, only for a project made with an older version of ExeOutput.

It’s still not working at this end, I’ve tried with several new projects - infact right from my first test of v2.2 I’ve been working with new projects right from the start.

Here are the steps I take…

1.Create a new project with my main dev folder as the app root.
2.Alter various settings for app as required.
3.Goto file manager
4.Click the exclude folders button
5.Tell it to exclude the two folders that contain lots of subfolders and files within
6.Save project
8.Activate test mode (no compression)
7.Attempt to compile the app - but compilation takes forever and I can still see all the supposedly excluded files being COMPRESSED and ADDED TO THE EXE.
8.Press abort and the compilation log confirms the excluded files were being both compressed and included in the exe

Am I doing something wrong?

The problem is that your folders are automatically added when you start a new project. So, use the Clear button.

Okay, so I seem to have figured out a method that works…

After excluding the folders with the exclude folders button, I also have to “Destroy” them with the clear button too - then they permanently dissappear from the main folder tree.

Maybe to avoid confusion it could better to automatically add folders “destroyed” by the clear buitton to the excluded list on the fly? Currently they do dissappear when using the clear button alone, but unless also excluded, they reappear whenever a file update runs - thus the confusion!

Anyways, no worries - glad I’ve got it working at last! :smile: -)

NOTE: before I got it working I had downloaded and installed the temp fix for the file properties issue from here: File Properties Security Not Working - not sure it that was anything to do with why it started working, but all good either way!

1 Like

Thank you for the follow up!