EXE not rendering in brand new Win 11

I’m testing a executable compiled with PHP 7.4 in a brand new Windows 11 virtual machine. The exe opens but screen does not change from “Just a moment, please…” message.
Then I realize the exe depends on Chromium to run.
Ok, downloaded latest Google Chrome and… same result.
I wonder if there is another library required by EXEOutput to install in a new windows machine.

PS: Already tried the deployment option “create a portable option”.
Other details: strangely, it will run if compiled with PHP 7.2 - not ideal at all because of some libraries used that requires 7.4.

More details:
Compiled the General Demonstration Sample. Worked on Windows 10, not on Windows 11, same message…

Normally, it works on Windows 11. PHP runtime requires Visual C++ Redistributables. Although ExeOutput can compile them into the EXE, this can be disabled with an option.
So, try to install these runtimes on your Windows 11 OS:

The VC15 and VS16 builds require to have the Visual C++ Redistributable for Visual Studio 2015-2019 x86 installed

Hi, thanks. This resolved the problem. I was installing the VC for x64, not x86.

1 Like