Executable startup failures

A brand new bug has raised its head. A number of times when launching the exe file from ExeOutput it will paint the window frame and stop. Most of the times the inside is simply a pale blue but on occasion (like this moment) the entire content pane is transparent. When this happens (either) it leaves a ghost process running that must be closed via monitor.

The exe is then unable to be launched successfully. I’ve tried just relaunch and recompiling, dropping ExeOutput and it takes a number of attempts (without recompile) before the application will launch successfully.

One minor bright note, ExeOutput now remembers which monitor it was on at close. The executable still doesn’t.

That’s strange, the same code that deals with multi-monitors is both used in ExeOutput and the apps it generates. Try to reset the settings saved on the end user’s computer.

On which Windows version are you getting this problem? Could you send us a system report? Menu => About Box => Send System Report.

Just did that. Did not help. Windows 7 Ultimate. You can find the report here: /publishing.secondgods.com/MOBI/Nov29 2017.nfo

Try to update your graphic driver. May be a problem related to the CEF engine.

Done, all drivers are current. No change. Like I said, it worked perfectly until update. Problems started with no change on my side at all.

Loading characteristics are:
Most times it will flash a pale blue window w/ no content.
Fewer times it will launch successfully.
Fewer times still it will launch w/ transparent window.

Viewing the monitor:
When there’s a successful launch, two subordinate processes and all close out successfully on exit.
When there’s a failed launch, two subordinate and an additional process appears. When this happens the duplicate stays in the background and must be closed manually. On rare occasions, two processes have to be closed manually.

Could you check the option:
and see if it helps?

Launched ten times in a row without problem. How will this affect the final product?

Nothing special will occur. It’s just an old version of our virtualization system. It’s less optimized that the current one, but in your case, it seems to help. Do you think you could share the faulty EXE file with us, so that we can track what could happen?

You can find the executable files index.exe and Jacket Construction.exop at /publishing.secondgods.com/MOBI

You might have to wait a bit (from now) as they’re large.

You can delete the files, we have got them. Thanks!

No problemo.

I have had this same exact problem, only difference is I only recently bought this software so I didn’t have the experience that it used to work right. Anyway I tried checking the “Legacy virtual file system” like you stated, and that seems to work. I have tested it on 3 different computers and so far it has not failed to launch yet. Thanks so much. I am getting ready to deliver my product to the customer, are there any issues with selecting that checkbox that I should be aware of? Thanks so much

Same here. It has become worse as of late and had just excepted it “just the way it is”. Was going to try the Legacy virtual file system option but now my software is in trial mode even though activate maintenance…

Selecting the Legacy virtual file system option did seem to work. I have not had any more problems since I selected that.

1 Like

There is no problem nor reason not working with the legacy file system, except maybe an application a bit slower. Obviously, something is wrong in the new one for some customers and we’re investigating.

1 Like