ExeOutput and Scriptcase [SOLVED]

I was excited to come across a product such as this and downloaded the eval immediately.

Alas, nothing I do seems to get the code to work. The error remains “Common libs not found: …/Data/app_Login/_lib/prod”. I have replaced my execoutput install directory with “…” for brevity here.

The problem is, the actual folder has amongst other folders:


I’m at a loss why ExecOutput is looking for the common libs under “…/Data/app_login/_lib/prod” when the source folder shows them located under “…/_lib/prod”. In troubleshooting, I have used File Explorer/ properties to set ALL files under …/_lib/prod to be unpacked into virtual memory but it has made no difference.

Any pointers would be greatly appreciated. Attached is the log file.

Thank you

Are you using any PHP framework? Maybe there is a problem with the PHP’s include function.

I’m using a RAD tool: Scriptcase. How can I troubleshoot the include functions? The included files are all present and its a standard php construct: why should it be a challenge here?


Does your Scriptcase use .htaccess redirections?

You should send a sample to our support team at http://www.exeoutput.com/contact.php so that they can study how this works.

No it uses no .htaccess redirections whatsoever. Just includes.

paste some source code if you need help, without source code we can’t help you

Is it possible for you to send us a project by PM? Please zip it, upload it to http://demo.ovh.com/en and send the link by PM.

I’ve sent the zipped app and sent a message by PM through this forum. The message still shows in outbox (rather than sent items) so its not clear if it has reached you.

Got your file. I’ll study it.

Still no luck with this yet?

It looks like that ExeOutput for PHP v1.6 works with the sample you sent me.
Scriptcase requires some PHP extensions as explained in their documentation:

When I run the sample, I get a menu and no error at all:

That would be just awesome. I’ll try out the full app and see.

Thank you