Modify language of the welcome screen

How can I modify the language of the buttons like “Original Workbook” in my own language? Unfortunately, only the text above changed to German.

Thanks for help!


Start with the German - Deutsch .Sil file in the XLSPadlock home directory. The only one I believe you cannot modify is the “Original Workbook” menu option. I have been asking XLS tech support how to do it for over one year now with no reply.

1 Like

Thanks for your reply. Yes, thats the point. I can not modify the buttons. Everything else is in my language.

It sounds like the .Sil file you are using may have been altered/corrupted to the point it is not compiling it correctly. I would try to re-create a new test .Sil file. Test by using the default English.Sil file and search for “Choose Save File” and replace it with your language then re-compile and check the results. You can simply test this by using any Excel file. Remember, I have contacted tech support many times regarding modifying the “Original Workbook” button/menu option but I cannot find an answer from them. All other portions of the opening screen can be modified.

I find it quite unusual that you’re experiencing this issue. Typically, in the English.sil file, you should be able to modify the text for the “Original Workbook” button by accessing the line:
Tfwelc.boriginalworkbook=Original Workbook~!@#$
(Line 24)
If this isn’t working for you, or if you encounter further issues, please let us know.