Mysql manualy started


Is it possible, (and so how to), to start Mysql server manually for ExeOutPut ?


Sure, use this HEScript code:

 ST: string;
 ST := IncludeTrailingBackslash(ExtractFilePath(GetGlobalVar("HEPublicationFile","")));
 RunAProgram(ST + "mysql\bin\mysqld.exe", "--defaults-file=mysql\my.ini --standalone ", ST, false, SW_HIDE);

Thank-you, I am going to try right now !

What about closing mysql connection manullay ?

It’s working, now I only need the closing HEScript code please !

ST := IncludeTrailingBackslash(ExtractFilePath(GetGlobalVar("HEPublicationFile","")));
RunAProgram(ST + "mysql\bin\mysqladmin.exe", "shutdown -u root -p" + SP, ST, false, SW_HIDE);

Replace ROOTPASSWORD by corresponding value.

1 Like

It works to, but when i try to start mysql again it doesn’t work !

Strange. Have you checked that after running the 2nd code, the mysqld.exe daemon process is closed?

Yes, it is closed !

Change the start code to:

IncludeTrailingBackslash(ExtractFilePath(GetGlobalVar(“HEPublicationFile”,""))); RunAProgram(ST + “mysql\bin\mysqld.exe”, "–defaults-file=mysql\my.ini --standalone ", ST, false, SW_SHOWNORMAL); end;

and see if there is any error displayed when you start MySQL.

Error in script:
Unknow identifier or variable is not declared: ‘SW_SHOW’


1 Like

First time start, dos windows displayed.
Second time, after closing mysql, doen’t show nothing !

Thank-you anyway !

same problem here sir.

Is there now an update for this solution sir? b4, i dont have the type of problem like this until i adopt exeouput 2019. THe shutdown hescript code work! . but for start hescript code for mysql doesnt work.

to make it work i have to run the wamp server to run the database. please need for a salvation.

You said you have a problem restarting the server one more time?

yeah even if i check or uncheck the

still having the error. even when uncheck and manually operate using hescript. The Shutdown hescript work! but start script doesn’t work!. even though it has a blink appearance of cmd( maybe its the mysqld).

That means the server had a fault for restarting. Please check the logs in the “mysql” subfolder.