Online activation in protect eBook not working for names with special characters

Hi,

I am using HTML Executable (version 4.9.5.0) and Protect eBook to manage my customer subscriptions.

My customers use Online Activation and it usually works just fine. However, I have issues if the name the user is trying to register with contains special characters such as “ä”, “ö” or “ü” (which are a frequent part of names in Germany, where a part of my customer base resides). I narrowed it down to this issue by manually generating a test customer and switching his name around - activation always worked flawlessly on “normal” names and never worked with those special characters.

Those users are presented with a generic error message (Activation not successful: the application could not be registered with the received data. Please contact the author.) without any specific error code. I am able to manually generate keys for them, but this is clearly a workaround.

Is there any way to fix this issue by adjusting settings in HTML Executable for the generation of the publication or is this something on your end that would need to be fixed?

Best regards,

Andreas

Looks like to be a UTF-8 encoding problem. How do you add your users to the Protect Ebook.net service? Manually? With a script from a reseller?

I am using a script from a reseller, FastSpring to be precise. This script hasn’t been adjusted or changed in any way for several years now, though.

This problem that I described started happening after I upgraded to a new version of HTML Executeable, the eBooks rendered with 4.9.0 did have no activation issues whatsoever.

If you open the Protect Ebook client and edit a customer that was added with the FastSpring script, is the name correct?

Yes, the name including special characters is shown correctly in the client (however online activation doesn’t work in that case). If I then manually edit the customer’s name in the Protect eBook client to not have special characters, it works flawlessly again. If I change manually change it back, it breaks again.

It may be a problem in the last 4.9.5 update, we will fix that in next minor update.

Do you have an ETA on that update already? Because I am getting quite a few customer complaints regarding this issue and would like to resolve it as quickly as possible.

Hi again,

I am sorry to bug you once more, but is there any update on this issue that you could share?