Split after "x" lines with header, first line added to header line

Not sure why when I add a header to each split part the first row of the part gets added to the header? Is there a way to avoid this?

What settings did you use in GSplit?

I have added an attachment of the settings. The file is a CSV file opened in excel which is quite large and needs to be broken into 300 line csv files. I need the heading of the original file to be the heading of each csv file.

AFAIK there is a setting in Excel to import or not the first row (or consider it as a header)