Trial period expired when it shouldn't be - SOLVED

Edit 3:
I found the reset button :slight_smile:, so please just ignore this post.


I’m trying to make a trial version of an existing project, and use the default certificate with a 30 days validity. But I just get “Trial period expired” on the nag screen. This even happens when making a portable version, where the license info is stored on disk, which is weird. I can make a new project with the same files, and then it works. Any idea why it won’t work with the existing project?

I found that if I remove the 30 days expiration, it works. But as soon as I set the expiration (no matter if it’s 1 or 3000 days), the problem is there again.

Also, if I set it to expire after a number of runs, it works.

I have also tried deleting the registered certificate, to no avail.

Edit 2:
I have found that whatever you put in the default certificate when first compiling the exe, sticks. So if I put in 5 days at first, I can’t change this later to e.g. 30 days. It stays at 5 days no matter what (unless I select no access without registration). If I select no access without registration at first build, I can’t change this later to a time limited certificate (but I can change it to number of runs limited).

I guess this is not by design, since there’s no way to “deactivate” the default certificate. So the only way to make a trial version is to start a new project. You can’t clone it, since the setting sticks then as well. You have to start from scratch, which is kind of a pain when you have lots of custom settings.

To solve your problem without starting a new project, you must clear the data saved by the ebook on your computer. If you play with trial dates, the ebook will detect it and expire the trial.

Do this:

Yes, I already figured this out. Thank you!