Uncaught SyntaxError Unexpected token <

I keep seeing this error in dev console and have no clue about:

Uncaught SyntaxError: Unexpected token < A6jgtE9JLYQNAtqLV0gMsRH-Q8.js:1


Any ideas?

@gdgsupport Could you at least give me some tips to troubleshoot this issue?

Do you still get it with ExeOutput 2.2? Does http://heserver/cdn-cgi/apps/head/_A6jgtE9JLYQNAtqLV0gMsRH-Q8.js exist?

Yes, sure do. Updated to 2.2 and tried before asking again:)

So does http://heserver/cdn-cgi/apps/head/_A6jgtE9JLYQNAtqLV0gMsRH-Q8.js exist?
Syntax error means that there is some problem within the JS file. Try to remove file compression for it (in the ExeOutput File Manager, right click and choose File Properties).

No, it does not exist. Not sure what /apps/head means (like in head of file?) but I have no scripts loading in head. Only three scripts on page are in footer: jquery-3.1.1.min.js, tether.min.js and bootstrap-4.0.0-alpha.6.min.js.

If you say it is not something within EXEOut, then I will have to troubleshoot my scripts. Never had this happen until I started using EXEOut V2.1 though.


No, it’s not a bug from ExeOutput (or maybe from CEF). Maybe you have a JS code that looks for that file? Since it doesn’t exist, ExeOutput returns nothing (404 error) thus the syntax error.