V2019 Hanging When Compile


#21

Thanks - it worked straight away, no need to activate.


#22

Great. And does compile work for you now?


#23

Yep, works fine - although I never had much of a problem anyway, it only happened a couple of times, I think @oldteacher would be the best for feedback on that!


#24

Perfect. Let us know if you still get that problem in the future. We’ll integrate the changes in ExeOutput 2019.1. Now waiting for @oldteacher feedback.


#25

Well, I honestly do not see much difference but only tried on laptop. Afraid to try on desktop and be completely out of service if something goes bad.

Here is what I see happening:

  • When first opening existing project and compiling, works flawless. Everything completes without hanging.

  • I make some changes to code using Notepad++ and recompile. This is when everything goes bad, on recompile. Might finish once but if I make further changes always hangs on a file (could be js, css or image).

  • Something I forgot to mention: I have starter projects created with V2 that I clone. I clone them and add content specific to job. Big time saver as many settings for specific school district already in place. Mention back in V2018 this 2018.3 File Compression Issue

Since I use mainly on “cloned projects”, maybe this is the issue? But, never had issue with totally hang until V2019 arrived.

Wish I could pin point exact issue. Real pain and time consuming to use now, as have to kill process and start over many times just to update older projects.


#26

Interesting, so it happens once the files were already compressed and cached once.
Did you try to enable/disable the option?
https://www.gdgsoft.info/uploads/default/original/2X/0/05f7f7dd19af6f223dbd5318e8b6dc78716902c5.png


#27

Moreover, have you tried to exclude your temp folder from antivirus?
The Clone option shouldn’t have an impact on compilation.


#28

Yes, I have tried the multi core on and off, no change.

Which temp folder are you speaking of?

But, I do not understand why I would all of a sudden need to exclude folders from anti-virus. Never had a moments problem in the past.


#29

Your local temp folder as explained here:
https://www.askvg.com/where-does-windows-store-temporary-files-and-how-to-change-temp-folder-location/
ExeOutput stores a compressed copy of each file temporarily. If you have a lot of source files, you’ll have a lot of temporary files. If your antivirus tries to scan each file, it will slow down compilation.


#30

Very good explanation, thank you. The link you provided leads to a page that simply says “denied”.

I hate to sound like a broken record, but I am using the same “exact” settings as in V2 and V2018. Neither one of those had this hanging issue:)

I will try the temp folder route.


#31

Your local temp folder as explained here:
https://www.askvg.com/where-does-windows-store-temporary-files-and-how-to-change-temp-folder-location/

I am assuming you are speaking of the “Windows Temp Folder @ C:\Windows” and not the AppData Local?


#32

Deleted all from both temp folders and found correct one.

Added AppData/Local/Temp to anti-virus exclude. No Change, still hangs.

Not sure how to proceed with exeout at this time. Something is defiantly wrong as cannot even cancel the process using “Cancel” button.

Will sit for hours if left and only way is to kill task.

Since I seem to be the only one having issue, guess both of my computers developed an issue.


#33

I took my laptop back to full reset (removed all files, apps and programs) and reinstalled only V2019. Exact same issue. No difference.


#34

You reinstalled V2019 and did you use the new build above?
When it hangs, is the progress bar always at 100% as on your screenshot above?


#35

Oh darn, I did not use the modified version. Have tried so many things, totally forgot. Have spend 80% of my time trying to get working and 20% actually working on projects:)

Will try and report back.

BTW: Noticed after trying the modified version first time, my firewall showed new alerts. is this version sending information somewhere?


#36

There is no hidden sending information: at startup, ExeOutput tries to download RSS feeds for the news and forum’s topics. That’s why your firewall detects something. The two other possible sending cases are: when you activate your copy and when you send a bug report with the Send bug report feature.

When it hangs, is the progress bar always at 100% as on your screenshot above? Because this will indicate us that the bug is not where we expected it.


#37

No, no - was not implying anything is hidden. Run a cisco firewall and for some reason it threw alert right after replacing / running new exe.

Trying now with modified version and will report back shortly.


#38

Sadly, same result. And yes to your question. Pretty much same behavior:

image


#39

I was just thinking back to when it happened to me - when I first installed 2019 I cloned my main project and switched to php7.3, and it was only during compilation of that that it froze a couple of times - not everytime, just a couple. After that (for other reasons) I recreated my project from scratch and have been using that fresh project ever since and it certainly hasn’t happened again.

@oldteacher I know it’s a pain to do, but have you tried re-creating the problematic projects from scratch? - I’m certainly not 100% sure, but I seem to remember the issue only occured for me with a cloned project at the time.


#40

Thanks for the insight @kim! Yes, I did try a fresh start and get the same results. Still hangs.

Luckily, most projects that I converted from Visual Studio can still be used and looks like going back to them. Since 90% of my business is done for schools, have a very strict policy to follow and all must be approved (which can take weeks). Looks like I will have to go back to Visual Studio on some projects, cannot afford to lose business:)